summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:15:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:26 +0200
commita495c6ad29930c53874bc9ee7d967b28a5a7f366 (patch)
tree6de380a832727d5b8c9e2fa69975683771952c82 /dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild
parentdev-ros/diagnostic_updater: Bump to 1.9.3. (diff)
downloadgentoo-a495c6ad29930c53874bc9ee7d967b28a5a7f366.tar.gz
gentoo-a495c6ad29930c53874bc9ee7d967b28a5a7f366.tar.bz2
gentoo-a495c6ad29930c53874bc9ee7d967b28a5a7f366.zip
dev-ros/rosdiagnostic: Bump to 1.9.3.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild')
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild
new file mode 100644
index 000000000000..f7437b193856
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"