summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:08:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:23 +0200
commite4a4c8b09bd0564ad6bb4d762a7ad528d3487697 (patch)
treee18e55ca76c1233acfb65e79a5ea2ac4e7f35c11 /dev-ros/rosmaster
parentdev-ros/rosparam: Initial import. Ebuild by me. (diff)
downloadgentoo-e4a4c8b09bd0564ad6bb4d762a7ad528d3487697.tar.gz
gentoo-e4a4c8b09bd0564ad6bb4d762a7ad528d3487697.tar.bz2
gentoo-e4a4c8b09bd0564ad6bb4d762a7ad528d3487697.zip
dev-ros/rosmaster: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosmaster')
-rw-r--r--dev-ros/rosmaster/Manifest1
-rw-r--r--dev-ros/rosmaster/metadata.xml5
-rw-r--r--dev-ros/rosmaster/rosmaster-1.11.14.ebuild20
-rw-r--r--dev-ros/rosmaster/rosmaster-9999.ebuild21
4 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/Manifest b/dev-ros/rosmaster/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/rosmaster/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosmaster/metadata.xml b/dev-ros/rosmaster/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosmaster/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosmaster/rosmaster-1.11.14.ebuild b/dev-ros/rosmaster/rosmaster-1.11.14.ebuild
new file mode 100644
index 000000000000..7d6dc2f38ade
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.11.14.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosmaster/rosmaster-9999.ebuild b/dev-ros/rosmaster/rosmaster-9999.ebuild
new file mode 100644
index 000000000000..ec8fb4f31a65
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"