summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 18:43:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:50:45 +0200
commitea5f9c1a2f79efb740aa15d3235d401482134800 (patch)
treea17f78cb276dbddd5c3d4bb7d4e6d452c20b5891 /dev-ros/rospy_tutorials
parentdev-ros/roscpp_tutorials: Bump to 0.10.1. (diff)
downloadgentoo-ea5f9c1a2f79efb740aa15d3235d401482134800.tar.gz
gentoo-ea5f9c1a2f79efb740aa15d3235d401482134800.tar.bz2
gentoo-ea5f9c1a2f79efb740aa15d3235d401482134800.zip
dev-ros/rospy_tutorials: Bump to 0.10.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rospy_tutorials')
-rw-r--r--dev-ros/rospy_tutorials/Manifest1
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/Manifest b/dev-ros/rospy_tutorials/Manifest
index 57c7bd1e9d35..d465e57d307e 100644
--- a/dev-ros/rospy_tutorials/Manifest
+++ b/dev-ros/rospy_tutorials/Manifest
@@ -1,4 +1,5 @@
DIST ros_tutorials-0.10.0.tar.gz 159486 BLAKE2B 71b6fabb1a85ac9740dfba9f40be318e211d519189f8be05e58bf146b5d22566ea6ddcdca6331366c05e95c314b656c4f5688c4da3d20b1cdce78639a76e14c5 SHA512 dba529965bad64957721c71f1c7b2b60ece085ed0186a107fbec03c231940b19004b3bf9dce5c1ac3dcfe1c339d49a2214811d5227f453b1c3f541076a653048
+DIST ros_tutorials-0.10.1.tar.gz 159522 BLAKE2B b0e045c6ee62cb68dfa977d17125af23d8ef80a619e822d245531a6cb3520a4d53120769e74ae2ba9af2813ce968e0c4fb22b7655eadd13b1a720705a9f75374 SHA512 592edb84f2e0ea80b2757ae890f495e8cb93d867b1bc6d64e6446f28fcffbd48c05703ac30ac29fd184a689f465728a5958d8c747587c756b53341c1d0740684
DIST ros_tutorials-0.6.1.tar.gz 126792 BLAKE2B 5964c8fe5ddc736e9933b89f9c66eae436805ec5c564a2144c1e338537da18b2064e9aba209f25a82b7d88e5b2bd2e1401dbe931614f65544ae2f5170270ff1f SHA512 f09e5451030c0a76a9473020535e79ac06e748f4208109cf83e61526d13472c3390402814a3d145cb793c5418af703cd9959ca57143798d1706185c13d3418c5
DIST ros_tutorials-0.7.0.tar.gz 140125 BLAKE2B 9f1006c933b4cb642f77c8e68ddda92213b9cfd132131b2768c4fe17ef6b1b8bf8da89da3fea2a0692d340d9f0b1e953fb150e2dae9e18de86b59fe50b72cb74 SHA512 b7c51bc007c0bddfb38361750a0225606d9e85a3404d6b21f3a32c8ccb1786844f225a49ad8f525c684c838eff9ec9f7e7c39a15adf5ea5dd187a59c90144711
DIST ros_tutorials-0.7.1.tar.gz 140483 BLAKE2B 8f2d4aee6494476bf7efb2ea35962ea6154485143f108b8e7603a9a1e67cb76f6c87e7b2612cd07ba19c50b44cd7fbbcd89f13f902eafd17c2a0eb8738357050 SHA512 0970e6428af992addfa1af327b2e0a3f85a926c90cfceba89d415acc5404a364164e0dd497c9296f03ac06c575380ad21e83b0cdbf6709c49dc650087145ddaa
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild
new file mode 100644
index 000000000000..31948ff70209
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"