summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-20 14:32:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-20 16:21:47 +0100
commitcf2657dea435babfdadd3dfee29f1e45de714876 (patch)
tree8718ad55d8cafb7436d0a0a92c0911d5b52b84c9 /dev-ros/rostest
parentdev-ros/rosservice: Bump to 1.12.7. (diff)
downloadgentoo-cf2657dea435babfdadd3dfee29f1e45de714876.tar.gz
gentoo-cf2657dea435babfdadd3dfee29f1e45de714876.tar.bz2
gentoo-cf2657dea435babfdadd3dfee29f1e45de714876.zip
dev-ros/rostest: Bump to 1.12.7.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rostest')
-rw-r--r--dev-ros/rostest/Manifest1
-rw-r--r--dev-ros/rostest/rostest-1.12.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/rostest/Manifest b/dev-ros/rostest/Manifest
index e92826da59ec..6f8a08f5513b 100644
--- a/dev-ros/rostest/Manifest
+++ b/dev-ros/rostest/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.12.6.tar.gz 967763 SHA256 8585d952b1168d2011949b38c68160180b1f3ee1648a506bcb5989f9807335ca SHA512 1987c6362ae0c7c019a226223c73a7aefdc14a3fc66469ab6cdf9c41e9efdf4d7b7d4932af2a52f2082d716342a307b2e415c0ab45f77dfd9a7c1e4274deab5c WHIRLPOOL a719bb81da6b1b7e2f253d3bf6c8db8339333b4fa7f89a18d0fa734e9ff1700e1dac7b537f154015b4ada7455a6673c1715a89e2fdd3da9bbbb70081fc2943cd
+DIST ros_comm-1.12.7.tar.gz 974568 SHA256 4c141270c9263ba1ceb0d510f9d17bfe229530a277bfe10762e88d25f46efd38 SHA512 7cfc5bf231e8e388102f192d46bd902a2b92d4620938379b362efd250c48f317f5ba6e0aee7398c841392f56c2b79f933ad5ec60eb69492add90fa2ca86a3a8f WHIRLPOOL 7537aa5b781b3426cbaa82bdb07b117045efc3f748af7413e6b52ee63f3b401e403966afb1ea305674a5613f6a191f0afa098ad16e63267ad2ec8e3117996eb0
diff --git a/dev-ros/rostest/rostest-1.12.7.ebuild b/dev-ros/rostest/rostest-1.12.7.ebuild
new file mode 100644
index 000000000000..098ad0368304
--- /dev/null
+++ b/dev-ros/rostest/rostest-1.12.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Integration test suite based on roslaunch that is compatible with xUnit frameworks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ ${RDEPEND}
+ dev-cpp/gtest
+ )"