summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-10 10:53:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-10 11:34:51 +0100
commitdcfc2b5710b224d60447e13ea0a68897ecf4a7f4 (patch)
treeff6a241795695946f641f2ce05df77bdd90f6cf4 /dev-ros/rqt_graph
parentdev-ros/rqt_dep: Bump to 0.3.13. (diff)
downloadgentoo-dcfc2b5710b224d60447e13ea0a68897ecf4a7f4.tar.gz
gentoo-dcfc2b5710b224d60447e13ea0a68897ecf4a7f4.tar.bz2
gentoo-dcfc2b5710b224d60447e13ea0a68897ecf4a7f4.zip
dev-ros/rqt_graph: Bump to 0.3.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_graph')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.3.13.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
index a503bd56f8f3..cd2a92898b85 100644
--- a/dev-ros/rqt_graph/Manifest
+++ b/dev-ros/rqt_graph/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.3.12.tar.gz 231733 SHA256 602ceea814b152865cd55c140565ec82d72277d9de75b869ce9fd3ac5a17b749 SHA512 567fb85324a85ef935379762026f7f3b5fbe491f61d947c273c1d138286acb919a2f458151b7137587bddbe028617934a75695a165fc7e7e6fd4b4cd87247b7d WHIRLPOOL d49809544f3de32129233c562f643afeed599b4f42688050aa433023188467243409ac048464eac05fc06f9a20c9d8992946dc68db0b01d7bcfde585a65fc42b
+DIST rqt_common_plugins-0.3.13.tar.gz 233815 SHA256 49c0a976dd6bb8ba1a4615bd1222fa0df191b9a40aef6c9d9d6be21d0d869a11 SHA512 b99b4f0c147dbaaa22ee773a12aa483ae95e60275bade58caf9bc570555fcbcc4b61054c2dee07dff99c4e33191620e4a3de16d8d9b5657e746076287cd83385 WHIRLPOOL 0469c66e2fe145d1f1c50d27101cbeb70d87b15ba896ffd86baf1c5cbc99bff2348ccbcc2997980bb0cd1cd6ead3733714406b7d3d45ead2d3b622771fe41c5a
diff --git a/dev-ros/rqt_graph/rqt_graph-0.3.13.ebuild b/dev-ros/rqt_graph/rqt_graph-0.3.13.ebuild
new file mode 100644
index 000000000000..9cbcb40f8b5b
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.3.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"