summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-05 18:59:26 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-05 19:26:40 +0100
commitf866a846b92d3b0b36f0807d804f0b0fcc10584b (patch)
tree1b7a40f3e65c7296c4a69a7e128d2fcbf1bc5a4b /dev-ros/rqt_py_common
parentdev-ros/rqt_publisher: Bump to 0.4.5. (diff)
downloadgentoo-f866a846b92d3b0b36f0807d804f0b0fcc10584b.tar.gz
gentoo-f866a846b92d3b0b36f0807d804f0b0fcc10584b.tar.bz2
gentoo-f866a846b92d3b0b36f0807d804f0b0fcc10584b.zip
dev-ros/rqt_py_common: Bump to 0.4.5.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_py_common')
-rw-r--r--dev-ros/rqt_py_common/Manifest1
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-0.4.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_common/Manifest b/dev-ros/rqt_py_common/Manifest
index fbf32ef8bc71..c2d7863a0a1c 100644
--- a/dev-ros/rqt_py_common/Manifest
+++ b/dev-ros/rqt_py_common/Manifest
@@ -5,3 +5,4 @@ DIST rqt_common_plugins-0.4.1.tar.gz 239721 SHA256 0fc1b6d443e346157baa7814f23e8
DIST rqt_common_plugins-0.4.2.tar.gz 241741 SHA256 6647c4cf40ed49804beca8a45927f78ac0274c37bd4e9f0ed629d20f92549173 SHA512 e83b4f50aadb3ee1b5c696b95b024ea55d39eaff113da8ecdc9f7f28ba97853c92b88438e02c18c3650874e13b14aacb5be0c6f426552e41c85b8cfe5ff48992 WHIRLPOOL fac39062a4a093877040c2cb21c8fbb83e7bf820ea8a18a95183c447622699927f0edb5e9beab2c907f927a4476c292f4906a9f8af6b0f995b377f752f1a8ce7
DIST rqt_common_plugins-0.4.3.tar.gz 242040 SHA256 a11a7cf416e6493776575e3795291a2a4cd215ce5c8090e4cd7cb361055db9c2 SHA512 91957bd70fe157e479ad982de7335210244479e238b814233f29b15f44f52cd443d890c0f626dccff69b55b462d514b879bb9e1321f4f9d169e28a42acba9ca7 WHIRLPOOL af7073935d6d7013342975ff8809dd0060c35d8a1fa92b289183f6e870246b4a3ab2214bdda545ed9644900b89822bedbf842284d34ee5b6b5fe8741537d4c24
DIST rqt_common_plugins-0.4.4.tar.gz 245149 SHA256 926b7835d4feea276518e9331de9bc3d25f8484ceb89d893948e6f2bf432cc7e SHA512 faa1e435aed0e158c802ac3b7cdf04a0fbf4cb340f2ed598970990827d384c5153a52657a474bf95af022166e5f6fb9acc926d1943b0093fea16c86699922d81 WHIRLPOOL 34848b6364af474072ef937f77deb583705db62a0e4ade7cc3b060e22af1a419c9beae4951791d81f0750619836cbbb9097956f9ec25f5768113dba253553d91
+DIST rqt_common_plugins-0.4.5.tar.gz 245843 SHA256 11edfe5c636957714ca7ac9a525f5cee6e7cf39048fbdf8a6484ca5cc3f6a926 SHA512 713cd232a12019026fae66cee1f2169b375ff8e359204b723057761953d5e15fc4aaffe99ded71cc237abe1d73d011454a8ba321c8a5401a0eceb9479e577325 WHIRLPOOL a2d1644651a79132087def58dbfdf39e333de26b5339767a72b4ac4af1baf7ce9af93908a57bf5fcc7f39c7e7d2464b12685727e2c48107723af43a9e759d8b0
diff --git a/dev-ros/rqt_py_common/rqt_py_common-0.4.5.ebuild b/dev-ros/rqt_py_common/rqt_py_common-0.4.5.ebuild
new file mode 100644
index 000000000000..d78d97b73ee1
--- /dev/null
+++ b/dev-ros/rqt_py_common/rqt_py_common-0.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for rqt plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"