summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-04 12:42:15 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-04 12:42:15 +0100
commitcfd4eadc7122b15631d700c28a522432098c8959 (patch)
treea90fd2124779915198b55fb086678a6fa1050e63 /dev-ros/sound_play
parentmedia-video/minitube: Remove myself as maintainer (diff)
downloadgentoo-cfd4eadc7122b15631d700c28a522432098c8959.tar.gz
gentoo-cfd4eadc7122b15631d700c28a522432098c8959.tar.bz2
gentoo-cfd4eadc7122b15631d700c28a522432098c8959.zip
dev-ros/sound_play: fix build without FEATURES=test, bug #567466
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/sound_play')
-rw-r--r--dev-ros/sound_play/files/test.patch26
-rw-r--r--dev-ros/sound_play/sound_play-0.2.9.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/sound_play/files/test.patch b/dev-ros/sound_play/files/test.patch
new file mode 100644
index 000000000000..e23490a1c3e9
--- /dev/null
+++ b/dev-ros/sound_play/files/test.patch
@@ -0,0 +1,26 @@
+commit ecdde483c81fb89e35f025ee3aacba7cd45528ab
+Author: Alexis Ballier <aballier@gentoo.org>
+Date: Fri Dec 4 12:38:42 2015 +0100
+
+ sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.
+
+ https://bugs.gentoo.org/show_bug.cgi?id=567466
+
+diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
+index ada0b07..3f9604c 100644
+--- a/sound_play/CMakeLists.txt
++++ b/sound_play/CMakeLists.txt
+@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
+ catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
+ INCLUDE_DIRS include)
+
+-catkin_add_nosetests(scripts/test)
++if(CATKIN_ENABLE_TESTING)
++ catkin_add_nosetests(scripts/test)
+
+-add_subdirectory(test)
++ add_subdirectory(test)
++endif()
+
+ install(PROGRAMS
+ scripts/playbuiltin.py
diff --git a/dev-ros/sound_play/sound_play-0.2.9.ebuild b/dev-ros/sound_play/sound_play-0.2.9.ebuild
index c4b4cb101276..be4ac3e90ddc 100644
--- a/dev-ros/sound_play/sound_play-0.2.9.ebuild
+++ b/dev-ros/sound_play/sound_play-0.2.9.ebuild
@@ -33,3 +33,4 @@ RDEPEND="${RDEPEND}
media-libs/gst-plugins-good:0.10
media-libs/gst-plugins-base:0.10
"
+PATCHES=( "${FILESDIR}/test.patch" )