summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-28 16:41:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-28 17:21:43 +0200
commit71dc8de68e5652c61ca6b5970df6f3b5387d6a36 (patch)
treee3b7245066b95f6a7586438b0e6c2934a04bbdb3 /dev-ros/test_bond/test_bond-1.8.2.ebuild
parentdev-ros/smclib: Bump to 1.8.2. (diff)
downloadgentoo-71dc8de68e5652c61ca6b5970df6f3b5387d6a36.tar.gz
gentoo-71dc8de68e5652c61ca6b5970df6f3b5387d6a36.tar.bz2
gentoo-71dc8de68e5652c61ca6b5970df6f3b5387d6a36.zip
dev-ros/test_bond: Bump to 1.8.2.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-ros/test_bond/test_bond-1.8.2.ebuild')
-rw-r--r--dev-ros/test_bond/test_bond-1.8.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_bond/test_bond-1.8.2.ebuild b/dev-ros/test_bond/test_bond-1.8.2.ebuild
new file mode 100644
index 000000000000..0853d20f14d8
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.8.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"