summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 10:00:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:53 +0100
commitccdd3fe6670c540d2c86f66b1c22c0abdc066710 (patch)
treee4c82c81413194bf7c89bde3f88caedaa21cf312 /dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild
parentdev-ros/test_rospy: Bump to 1.13.0. (diff)
downloadgentoo-ccdd3fe6670c540d2c86f66b1c22c0abdc066710.tar.gz
gentoo-ccdd3fe6670c540d2c86f66b1c22c0abdc066710.tar.bz2
gentoo-ccdd3fe6670c540d2c86f66b1c22c0abdc066710.zip
dev-ros/test_rosservice: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild b/dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild
new file mode 100644
index 000000000000..10a3f9d1abc5
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"