summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 16:50:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 16:53:39 +0100
commit04e4338ef7ef04120ffeed593bc623b3d684f926 (patch)
treeb4ad5c83760cccd86d420268b8cf7580c62d4f3c /dev-ros
parentdev-ros/visp_auto_tracker: Bump to kinetic version and 0.9.3. (diff)
downloadgentoo-04e4338ef7ef04120ffeed593bc623b3d684f926.tar.gz
gentoo-04e4338ef7ef04120ffeed593bc623b3d684f926.tar.bz2
gentoo-04e4338ef7ef04120ffeed593bc623b3d684f926.zip
dev-ros/visp_camera_calibration: Bump to kinetic version and 0.9.3. Fix build with gcc6 and boost 1.63
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/visp_camera_calibration/Manifest1
-rw-r--r--dev-ros/visp_camera_calibration/files/boost.patch24
-rw-r--r--dev-ros/visp_camera_calibration/files/gcc6.patch13
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.3.ebuild33
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild8
5 files changed, 76 insertions, 3 deletions
diff --git a/dev-ros/visp_camera_calibration/Manifest b/dev-ros/visp_camera_calibration/Manifest
index bff3bdf7a880..14f6b62e9882 100644
--- a/dev-ros/visp_camera_calibration/Manifest
+++ b/dev-ros/visp_camera_calibration/Manifest
@@ -1,2 +1,3 @@
DIST vision_visp-0.8.0.tar.gz 1010996 SHA256 5166e1f17601328d09716879ceb66135e07bdb71a375765a937e3b78a12b0e54 SHA512 2bf2d69b6e19de21b34869858672662162703ff8b2aea85fdb9a6dafa88d8fe1f97d18587e863f3f7c088697e931a1b6e4e2e37f31fc7caff0906e98debbad1a WHIRLPOOL 015778e4cff63a9dbb5bf5812e38f7564b68cb71886e472062be15ec31a87a7299bff7ef9df50124294e22906420f60075cf6cc69f77df1cd29267b401f655e5
DIST vision_visp-0.9.1.tar.gz 1014625 SHA256 918bf731a2fab8bd9fa082c0d0f86800710c79eeb9ec5e8b0c8d5baaffb7988d SHA512 f9ce23286fd9c7706364e9d63e6fb3881bad759aeea72313e5d2a24347f152ba90aab1c73d1b468ed3319e99f0a2bcb81208302825c83be686b9528f3b07469e WHIRLPOOL 8af772091c1c3fec475f32ff0d7232b728b3154491c4ed56300221c0ca96661c63c19baa50d6cdf010d1ffc304049f0ea1e7f5c403f15fb028b1417e41ed88b4
+DIST vision_visp-0.9.3.tar.gz 1014883 SHA256 bf51470d167b1ee202dc55348ad54f6398f0f951b3af06fd32d0689b2fa98347 SHA512 e5775e410efefaaac00cdfaf07b65f9f77ade0e7d6f40b3d8345d7b594520f46741f56039c1eb0193c57287bafbddf8e755e10d6f85cc12ddefb2b997681f44a WHIRLPOOL 9163c1aa27f405213aa7290d9e7ecb4b4f6d0daf79879708bd9246fac9eeb3c6b816de3505729b17cb72357e684bb7af9db6688441c42b279089fbdd8116acc0
diff --git a/dev-ros/visp_camera_calibration/files/boost.patch b/dev-ros/visp_camera_calibration/files/boost.patch
new file mode 100644
index 000000000000..e91630caa89e
--- /dev/null
+++ b/dev-ros/visp_camera_calibration/files/boost.patch
@@ -0,0 +1,24 @@
+Index: visp_camera_calibration/src/camera.cpp
+===================================================================
+--- visp_camera_calibration.orig/src/camera.cpp
++++ visp_camera_calibration/src/camera.cpp
+@@ -62,6 +62,7 @@
+
+ #include <visp/vpDisplayX.h>
+ #include "visp/vpTrackingException.h"
++#include <boost/format.hpp>
+
+
+ namespace visp_camera_calibration
+Index: visp_camera_calibration/src/image_processing.cpp
+===================================================================
+--- visp_camera_calibration.orig/src/image_processing.cpp
++++ visp_camera_calibration/src/image_processing.cpp
+@@ -69,6 +69,7 @@
+ #include "visp/vpDot2.h"
+ #include "visp/vpCalibration.h"
+ #include <iostream>
++#include <boost/format.hpp>
+
+
+ namespace visp_camera_calibration
diff --git a/dev-ros/visp_camera_calibration/files/gcc6.patch b/dev-ros/visp_camera_calibration/files/gcc6.patch
new file mode 100644
index 000000000000..48a77c9eee15
--- /dev/null
+++ b/dev-ros/visp_camera_calibration/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: visp_camera_calibration/CMakeLists.txt
+===================================================================
+--- visp_camera_calibration.orig/CMakeLists.txt
++++ visp_camera_calibration/CMakeLists.txt
+@@ -13,7 +13,7 @@ find_package(catkin REQUIRED COMPONENTS
+
+ find_package(VISP REQUIRED)
+
+-include_directories(SYSTEM
++include_directories(
+ ${BULLET_INCLUDE_DIRS}
+ ${Boost_INCLUDE_DIRS}
+ ${VISP_INCLUDE_DIRS}
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.3.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.3.ebuild
new file mode 100644
index 000000000000..094c5e84f9e7
--- /dev/null
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="kinetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of cameras using a customizable pattern and ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration_parsers
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/visp_bridge
+ sci-libs/ViSP:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+fi
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/boost.patch" )
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
index f71ea673dafa..094c5e84f9e7 100644
--- a/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
ROS_REPO_URI="https://github.com/lagadic/vision_visp"
KEYWORDS="~amd64 ~arm"
-VER_PREFIX="jade-"
+VER_PREFIX="kinetic-"
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
PYTHON_COMPAT=( python{2_7,3_4} )
@@ -24,8 +24,10 @@ RDEPEND="
dev-ros/roscpp
dev-ros/visp_bridge
sci-libs/ViSP:=
+ dev-libs/boost:=
"
DEPEND="${RDEPEND}"
if [ "${PV#9999}" = "${PV}" ] ; then
- S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+ S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
fi
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/boost.patch" )