summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:13:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 14:13:19 +0200
commit219fc400d5ff413859fb4b886dda562c98505363 (patch)
treedde7899d9735cc5caf4f0c454fe69acc63b35703 /dev-ros
parentdev-ros/rosmake: Initial import. Ebuild by me. (diff)
downloadgentoo-219fc400d5ff413859fb4b886dda562c98505363.tar.gz
gentoo-219fc400d5ff413859fb4b886dda562c98505363.tar.bz2
gentoo-219fc400d5ff413859fb4b886dda562c98505363.zip
dev-ros/rosunit: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosunit/Manifest1
-rw-r--r--dev-ros/rosunit/metadata.xml5
-rw-r--r--dev-ros/rosunit/rosunit-1.12.3.ebuild25
-rw-r--r--dev-ros/rosunit/rosunit-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/rosunit/Manifest b/dev-ros/rosunit/Manifest
new file mode 100644
index 000000000000..02c7ccc4a2ae
--- /dev/null
+++ b/dev-ros/rosunit/Manifest
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/rosunit/metadata.xml b/dev-ros/rosunit/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosunit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosunit/rosunit-1.12.3.ebuild b/dev-ros/rosunit/rosunit-1.12.3.ebuild
new file mode 100644
index 000000000000..b17b660292bc
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.12.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/rosunit/rosunit-9999.ebuild b/dev-ros/rosunit/rosunit-9999.ebuild
new file mode 100644
index 000000000000..b17b660292bc
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"