summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:23:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:31 +0200
commit50a91c17d6dce80cb42687275f04309fa72b19db (patch)
tree3e6854cfd78195ce6c5d79b8075b6a0da2907e40 /dev-ros
parentdev-ros/test_roslib_comm: Initial import. Ebuild by me. (diff)
downloadgentoo-50a91c17d6dce80cb42687275f04309fa72b19db.tar.gz
gentoo-50a91c17d6dce80cb42687275f04309fa72b19db.tar.bz2
gentoo-50a91c17d6dce80cb42687275f04309fa72b19db.zip
dev-ros/test_rosparam: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_rosparam/Manifest1
-rw-r--r--dev-ros/test_rosparam/metadata.xml5
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.11.14.ebuild27
-rw-r--r--dev-ros/test_rosparam/test_rosparam-9999.ebuild27
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/Manifest b/dev-ros/test_rosparam/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/test_rosparam/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/test_rosparam/metadata.xml b/dev-ros/test_rosparam/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/test_rosparam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/test_rosparam/test_rosparam-1.11.14.ebuild b/dev-ros/test_rosparam/test_rosparam-1.11.14.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.11.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"
diff --git a/dev-ros/test_rosparam/test_rosparam-9999.ebuild b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"