summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-27 10:20:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-27 10:34:25 +0100
commit6d4d943f8d65590ceaecc0f706b08f70bc59231b (patch)
treec0fd24bc12761eb3e2a598824aad9e1fc32bff85 /dev-ros
parentdev-ros/laser_cb_detector: remove old (diff)
downloadgentoo-6d4d943f8d65590ceaecc0f706b08f70bc59231b.tar.gz
gentoo-6d4d943f8d65590ceaecc0f706b08f70bc59231b.tar.bz2
gentoo-6d4d943f8d65590ceaecc0f706b08f70bc59231b.zip
dev-ros/laser_cb_detector: Fix build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/laser_cb_detector/files/gcc6.patch13
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild3
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/dev-ros/laser_cb_detector/files/gcc6.patch b/dev-ros/laser_cb_detector/files/gcc6.patch
new file mode 100644
index 000000000000..6580ca5e8453
--- /dev/null
+++ b/dev-ros/laser_cb_detector/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: laser_cb_detector/CMakeLists.txt
+===================================================================
+--- laser_cb_detector.orig/CMakeLists.txt
++++ laser_cb_detector/CMakeLists.txt
+@@ -15,7 +15,7 @@ catkin_package(DEPENDS actionlib actionl
+ )
+
+ find_package(OpenCV REQUIRED)
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
++include_directories(${catkin_INCLUDE_DIRS}
+ ${OpenCV_INCLUDE_DIRS}
+ )
+ include_directories(include)
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
index 6cecd2724ce3..ccd9c34bd21e 100644
--- a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,3 +27,4 @@ RDEPEND="
dev-ros/settlerlib
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
index 6cecd2724ce3..ccd9c34bd21e 100644
--- a/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,3 +27,4 @@ RDEPEND="
dev-ros/settlerlib
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )