summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-07-20 13:16:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-07-20 13:23:16 +0200
commit95e570de0e3d40f44629d177ba0a427ee5e783ce (patch)
treecb9e8c45d1a5200b616cfe0fec7883304169586d /dev-ros
parentdev-ros/roscpp: Remove old (diff)
downloadgentoo-95e570de0e3d40f44629d177ba0a427ee5e783ce.tar.gz
gentoo-95e570de0e3d40f44629d177ba0a427ee5e783ce.tar.bz2
gentoo-95e570de0e3d40f44629d177ba0a427ee5e783ce.zip
dev-ros/roscpp: upstream boost fix
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/roscpp/files/boost.patch26
-rw-r--r--dev-ros/roscpp/roscpp-1.14.3-r1.ebuild (renamed from dev-ros/roscpp/roscpp-1.14.3.ebuild)1
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/roscpp/files/boost.patch b/dev-ros/roscpp/files/boost.patch
new file mode 100644
index 000000000000..1d509a8ab6c7
--- /dev/null
+++ b/dev-ros/roscpp/files/boost.patch
@@ -0,0 +1,26 @@
+commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 31 00:58:29 2019 +0100
+
+ Remove signals from find_package(Boost COMPONENTS ...) (#1580)
+
+ The packages use signals2, not signals. Only boost libraries with
+ compiled code should be passed to find_package(Boost COMPONENTS ...),
+ and the signals2 library has always been header only.
+
+ Boost 1.69 has removed the deprecated signals library, so the otherwise
+ useless but harmless `signals` component now breaks the build.
+
+diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
+index a5d354ea6..8f462df2c 100644
+--- a/clients/roscpp/CMakeLists.txt
++++ b/clients/roscpp/CMakeLists.txt
+@@ -22,7 +22,7 @@ list(GET roscpp_VERSION_LIST 2 roscpp_VERSION_PATCH)
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/ros/common.h.in ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros/common.h)
+
+-find_package(Boost REQUIRED COMPONENTS chrono filesystem signals system)
++find_package(Boost REQUIRED COMPONENTS chrono filesystem system)
+
+ include_directories(include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+
diff --git a/dev-ros/roscpp/roscpp-1.14.3.ebuild b/dev-ros/roscpp/roscpp-1.14.3-r1.ebuild
index 4d1d63e2e341..15e970883b2a 100644
--- a/dev-ros/roscpp/roscpp-1.14.3.ebuild
+++ b/dev-ros/roscpp/roscpp-1.14.3-r1.ebuild
@@ -28,3 +28,4 @@ RDEPEND="
dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost.patch" )