summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:55:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 12:21:46 +0200
commit976e91207e01125509895288cf79b70609b30edd (patch)
treefc256447775f519ca69caea976c8277a76a2e707 /dev-ros
parentdev-ros/image_rotate: Bump to 1.12.20. (diff)
downloadgentoo-976e91207e01125509895288cf79b70609b30edd.tar.gz
gentoo-976e91207e01125509895288cf79b70609b30edd.tar.bz2
gentoo-976e91207e01125509895288cf79b70609b30edd.zip
dev-ros/image_view: Bump to 1.12.20.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_view/Manifest1
-rw-r--r--dev-ros/image_view/image_view-1.12.20.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/image_view/Manifest b/dev-ros/image_view/Manifest
index 202746fbd20e..b50ff7ba4d9b 100644
--- a/dev-ros/image_view/Manifest
+++ b/dev-ros/image_view/Manifest
@@ -1 +1,2 @@
DIST image_pipeline-1.12.19.tar.gz 130635 SHA256 fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97 SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba WHIRLPOOL ecb1cdcc07109d3781bb82e88c0fe7e91754b2dfac0bfc7f5d053e6df9ce78b95b4131a9b65715fbce1b44b0acab6f833bd9c0d4f2fb68718fee4f4bfd586c63
+DIST image_pipeline-1.12.20.tar.gz 137888 SHA256 b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53 SHA512 37a45cfcc8bdb8b40477860e29f72671d423d4531156f5901128c32a6c41d27f235cdac216502d614ab7ddab5e66c2f343baaa0fd22cf83cb38e667fbbc111c5 WHIRLPOOL 8dda5d84af0929a983e6a2cb54697ee50d3036399a05bff50ae711fb4e8638e8763de407b65beb14d65b2cd48e3b200c84af95cee7da48609448f102d0bfdadc
diff --git a/dev-ros/image_view/image_view-1.12.20.ebuild b/dev-ros/image_view/image_view-1.12.20.ebuild
new file mode 100644
index 000000000000..477a6ade7dc0
--- /dev/null
+++ b/dev-ros/image_view/image_view-1.12.20.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple viewer for ROS image topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ media-libs/opencv:=
+ x11-libs/gtk+:2
+ dev-ros/camera_calibration_parsers
+ >=dev-ros/cv_bridge-1.11.10
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"