summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-01-08 09:41:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-01-08 09:54:32 +0100
commitab6ee0a358292d15d743c8e57d7793aa460f0148 (patch)
tree4e42baf46afed14863043d14523b767122ae3985 /dev-ros
parentdev-ros/xacro: Remove old (diff)
downloadgentoo-ab6ee0a358292d15d743c8e57d7793aa460f0148.tar.gz
gentoo-ab6ee0a358292d15d743c8e57d7793aa460f0148.tar.bz2
gentoo-ab6ee0a358292d15d743c8e57d7793aa460f0148.zip
dev-ros/xacro: bump to 1.13.3
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/xacro/Manifest1
-rw-r--r--dev-ros/xacro/xacro-1.13.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/xacro/Manifest b/dev-ros/xacro/Manifest
index 0a7c4d381fd2..d617b691cfb5 100644
--- a/dev-ros/xacro/Manifest
+++ b/dev-ros/xacro/Manifest
@@ -1 +1,2 @@
DIST xacro-1.13.2.tar.gz 81163 BLAKE2B 3c4319ee0b0ad14f6310d8ce9ead7cf18c71285b5c601282b9951173eb2d7bbf0e9752d813b478bd340de29bacfd25e57166c018d7dd703377198773c3326203 SHA512 10a8498c48aa52b4b4930e2b59a3ad8be32b1b974ca5cb1c56f06ce5cb7866473a7f3d29cf37ffc0681c54f4377edcab327a302225429d32eb3cd26bdd322198
+DIST xacro-1.13.3.tar.gz 81173 BLAKE2B 19cbc50a9d57d41c1189e52c24dbc8bbf89b66a910ea646be44b6394c93961c87f0c697da1a1edd715809adf58db27a7e7b74101e005514844388cb57cb9920a SHA512 8ca12483d55d338289f42bfbaefcca8f4f95da3b884e29532c8a32f3d43f98d78150e4cc2683e6bd976d38d22ff37ffccdba0790b5a74b846a9068a7254bcc02
diff --git a/dev-ros/xacro/xacro-1.13.3.ebuild b/dev-ros/xacro/xacro-1.13.3.ebuild
new file mode 100644
index 000000000000..f3ebf72d0a8a
--- /dev/null
+++ b/dev-ros/xacro/xacro-1.13.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/xacro"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="XML macro language"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${RDEPEND}
+ dev-ros/roslaunch[${PYTHON_USEDEP}]"