summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-24 18:10:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-24 18:23:30 +0200
commitae5d5f51e2194aafc8cff1b4c56c468e0b32ab52 (patch)
treeed29e9be67e6d44674847e8fbc751424790f57d3 /dev-ros
parentros-meta/imu_tools: Bump to 1.2.1. (diff)
downloadgentoo-ae5d5f51e2194aafc8cff1b4c56c468e0b32ab52.tar.gz
gentoo-ae5d5f51e2194aafc8cff1b4c56c468e0b32ab52.tar.bz2
gentoo-ae5d5f51e2194aafc8cff1b4c56c468e0b32ab52.zip
dev-ros/roscpp_tutorials: Bump to 0.9.1.
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/roscpp_tutorials/Manifest1
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-0.9.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/roscpp_tutorials/Manifest b/dev-ros/roscpp_tutorials/Manifest
index 60d1f3ae6a0c..4090a6a26faa 100644
--- a/dev-ros/roscpp_tutorials/Manifest
+++ b/dev-ros/roscpp_tutorials/Manifest
@@ -4,3 +4,4 @@ DIST ros_tutorials-0.7.1.tar.gz 140483 BLAKE2B 8f2d4aee6494476bf7efb2ea35962ea61
DIST ros_tutorials-0.8.0.tar.gz 153739 BLAKE2B 0dc7918a2b95a26518d07d753040e381b26c357eb3995a22a429d58c244751d7c58c8736efbab23a6a5ca6903f08e43acf9519f2a534b22fe89ea853b2e3fbff SHA512 269f71ef360f7441e1bfed2c2b3da791ce8018d6ec833a1fb7198d289067359b1e7704e37580c61188cc45034c788f3ca463882f8247a155752ff5c61939d795
DIST ros_tutorials-0.8.1.tar.gz 153831 BLAKE2B c34aec17ffd247554e37abb252848183392864c801dce7e2cae8c66d9fd30fdb12d50163487eff8615593df1532dece6c86303aab0b91d4075c14a9fba652b5a SHA512 f537312a78c27375791e11820f4d3a70433ce200d724d80bc8b417edd3c6dcbbf72abac0e9a98a199da2e3a8dbdec34e81d9106be4f6a5243a6f84d02d9ca668
DIST ros_tutorials-0.9.0.tar.gz 154992 BLAKE2B d7a45d0adaa1507ae9494ea9590b9c69d3bbececa01f209a93825432b4b362499cde8c966e6734dbd854478e98970c340403ac56cb99a00b07cf9cff8b28fa36 SHA512 7beba72d3f72943ea5402416dc03809576d47d4e76e81d9ed85eba69c1f9a4e5737a91bdac76747f47e9d6459e5dd8e062cc8ec5f2fb9450cdb013b416534e56
+DIST ros_tutorials-0.9.1.tar.gz 155151 BLAKE2B 7371063ef77981892fee54b6b3d29907421f29deece22c6d53ace576717357a9700a2e14a03bd9f24c2285a16b55f5c9665a0da5081ae1599da8df5ec68ba425 SHA512 62a980e9515515496de39aa360df030f0dd8678bbf132d90386775c34e3b54f33a477aaefb65db803dcd704b8fbc61d445617399ac38cc2fa3f3363a6052682f
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-0.9.1.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.9.1.ebuild
new file mode 100644
index 000000000000..ce7133ab81ce
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.9.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"