summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 16:19:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:40 +0200
commitd574fac9e5441907ef43d34d395bb86794bae1bb (patch)
tree40a4ba2d1df69f668a058b34f0f1f9bad60cf8e6 /dev-ros
parentdev-ros/cv_bridge: Remove old (diff)
downloadgentoo-d574fac9e5441907ef43d34d395bb86794bae1bb.tar.gz
gentoo-d574fac9e5441907ef43d34d395bb86794bae1bb.tar.bz2
gentoo-d574fac9e5441907ef43d34d395bb86794bae1bb.zip
dev-ros/cv_bridge: fix boost python detection
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild3
-rw-r--r--dev-ros/cv_bridge/cv_bridge-9999.ebuild3
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch17
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild b/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild
index 781df6ff0219..422225d82b4f 100644
--- a/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild
+++ b/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,3 +21,4 @@ RDEPEND="
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boostpython.patch" )
diff --git a/dev-ros/cv_bridge/cv_bridge-9999.ebuild b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
index 091646aa633e..422225d82b4f 100644
--- a/dev-ros/cv_bridge/cv_bridge-9999.ebuild
+++ b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,3 +21,4 @@ RDEPEND="
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boostpython.patch" )
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
new file mode 100644
index 000000000000..72fac8087363
--- /dev/null
+++ b/dev-ros/cv_bridge/files/boostpython.patch
@@ -0,0 +1,17 @@
+Index: cv_bridge/CMakeLists.txt
+===================================================================
+--- cv_bridge.orig/CMakeLists.txt
++++ cv_bridge/CMakeLists.txt
+@@ -5,11 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+
+ if(NOT ANDROID)
+ find_package(PythonLibs)
+- if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
+- find_package(Boost REQUIRED python)
+- else()
+- find_package(Boost REQUIRED python3)
+- endif()
++ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
+ else()
+ find_package(Boost REQUIRED)
+ endif()