summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-12 13:58:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-12 13:59:46 +0200
commite67f21cb3d46a740efc2bbad0cc83bbef98a6ea2 (patch)
treeb430f1ade8fecb05da25bad950ebc8b9dc7ebd2e /dev-ros
parentdev-ros/image_publisher: add missing boost dep (diff)
downloadgentoo-e67f21cb3d46a740efc2bbad0cc83bbef98a6ea2.tar.gz
gentoo-e67f21cb3d46a740efc2bbad0cc83bbef98a6ea2.tar.bz2
gentoo-e67f21cb3d46a740efc2bbad0cc83bbef98a6ea2.zip
dev-ros/image_rotate: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_rotate/Manifest1
-rw-r--r--dev-ros/image_rotate/files/gcc6.patch34
-rw-r--r--dev-ros/image_rotate/image_rotate-1.12.19.ebuild29
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-ros/image_rotate/Manifest b/dev-ros/image_rotate/Manifest
index b50ff7ba4d9b..f6e12d8df502 100644
--- a/dev-ros/image_rotate/Manifest
+++ b/dev-ros/image_rotate/Manifest
@@ -1,2 +1 @@
-DIST image_pipeline-1.12.19.tar.gz 130635 SHA256 fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97 SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba WHIRLPOOL ecb1cdcc07109d3781bb82e88c0fe7e91754b2dfac0bfc7f5d053e6df9ce78b95b4131a9b65715fbce1b44b0acab6f833bd9c0d4f2fb68718fee4f4bfd586c63
DIST image_pipeline-1.12.20.tar.gz 137888 SHA256 b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53 SHA512 37a45cfcc8bdb8b40477860e29f72671d423d4531156f5901128c32a6c41d27f235cdac216502d614ab7ddab5e66c2f343baaa0fd22cf83cb38e667fbbc111c5 WHIRLPOOL 8dda5d84af0929a983e6a2cb54697ee50d3036399a05bff50ae711fb4e8638e8763de407b65beb14d65b2cd48e3b200c84af95cee7da48609448f102d0bfdadc
diff --git a/dev-ros/image_rotate/files/gcc6.patch b/dev-ros/image_rotate/files/gcc6.patch
deleted file mode 100644
index e0737b47cbc7..000000000000
--- a/dev-ros/image_rotate/files/gcc6.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 6c2d65452bd5fe62723988a1a570789921900d59
-Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Fri Sep 30 15:39:47 2016 +0200
-
- address gcc6 build error
-
- With gcc6, compiling fails with `stdlib.h: No such file or directory`,
- as including '-isystem /usr/include' breaks with gcc6, cf.,
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
-
- This commit addresses this issue for this package in the same way
- it was addressed in various other ROS packages. A list of related
- commits and pull requests is at:
-
- https://github.com/ros/rosdistro/issues/12783
-
- Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-
-diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
-index 04ba03b..75d8e77 100644
---- a/image_rotate/CMakeLists.txt
-+++ b/image_rotate/CMakeLists.txt
-@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
- find_package(Eigen REQUIRED)
-
- # add the executable
--include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
-- ${EIGEN_INCLUDE_DIRS}
-- ${OpenCV_INCLUDE_DIRS}
--)
-+include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
-
- add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
- target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})
diff --git a/dev-ros/image_rotate/image_rotate-1.12.19.ebuild b/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
deleted file mode 100644
index 07b7cc7a3b3a..000000000000
--- a/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Rotates an image stream minimizing the angle between an arbitrary vector and the camera frame"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cv_bridge
- media-libs/opencv:=
- dev-ros/dynamic_reconfigure
- dev-ros/eigen_conversions
- dev-ros/image_transport
- dev-ros/nodelet
- dev-ros/roscpp
- dev-ros/tf2
- dev-ros/tf2_geometry_msgs
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )