summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-30 15:28:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-30 15:32:45 +0200
commitf512c74535843a649dbd89fab8024b2b9ad7e604 (patch)
tree9fa50f417739804bef14560e275fe04d94cf2dc8 /dev-ros
parentnet-libs/miniupnpc: amd64 stable (diff)
downloadgentoo-f512c74535843a649dbd89fab8024b2b9ad7e604.tar.gz
gentoo-f512c74535843a649dbd89fab8024b2b9ad7e604.tar.bz2
gentoo-f512c74535843a649dbd89fab8024b2b9ad7e604.zip
dev-ros/geodesy: Bump to 0.5.3.
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/geodesy-0.5.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
index 8cf8464d7f13..25044fdda2f9 100644
--- a/dev-ros/geodesy/Manifest
+++ b/dev-ros/geodesy/Manifest
@@ -1 +1,2 @@
DIST geographic_info-0.5.2.tar.gz 27336 BLAKE2B f864d8b70b5b0d797cec81e25a25d0dd708bcc49c169f68216616d900b1d11918583f6f5ec4a919ad03b08ee86b2a36cde575c1054c58a93974d4c4faf6e2aae SHA512 8b512399ef61ebfb9816c613ed4fcde23ec52a9b4bbd1bb7268c8ec7fe03b1a157435fef17b8af72fdf88ce6ed0b9130473183402e0875a25eac0ac46df0d00d
+DIST geographic_info-0.5.3.tar.gz 27446 BLAKE2B 51463f872829224c618b1d37c3d07ba53ee00b4f3e48bbc202d9ab4abfe8db8148dbbfdb6780af5aaf36ab9e9a7dca973b603a22139a192a96f6bcef87fa52a5 SHA512 681aad5ba62363cf96255351e884c8ba8d3110571e6e97c9340f8d15f38183900c2a04e109416b4113a0a042ebd9cdb8fe075c507200dac06052b444f4212ab3
diff --git a/dev-ros/geodesy/geodesy-0.5.3.ebuild b/dev-ros/geodesy/geodesy-0.5.3.ebuild
new file mode 100644
index 000000000000..c2cd15d3b654
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"