summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/activeldap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/Manifest2
-rw-r--r--dev-ruby/activeldap/activeldap-3.2.2.ebuild42
-rw-r--r--dev-ruby/activeldap/activeldap-4.0.4.ebuild40
-rw-r--r--dev-ruby/activeldap/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/Manifest b/dev-ruby/activeldap/Manifest
new file mode 100644
index 000000000000..93565200cf2f
--- /dev/null
+++ b/dev-ruby/activeldap/Manifest
@@ -0,0 +1,2 @@
+DIST activeldap-3.2.2.gem 218624 SHA256 2c8f1c5ca5d32ef6c98cc9ad00933a10b3ed9fc0d77eaea504a5615e6e37ece0 SHA512 f3a802fa1e05b2140fc0c14035ce4ec7037496a2de50908a1143bf3a2c89cf9de6a339ead075b38e7f8b8f7f78314cfd9fe414b64e71e89bdd8dce6b9ab7a1ad WHIRLPOOL a07beca35e89738cc1fa39c5cfd193a63240708ab857812795fe02c148e73ef2e9e1865e286d82608c8fbbf78e4f87c6afc66f8a506b0de51550a0dd006bff6a
+DIST activeldap-4.0.4.gem 223744 SHA256 837f2a3b3249a0be1c53d4b063422a1cf021cf9f746b8dbce4d4fefbcb7460fb SHA512 24ca2c07ecab2d1b96b7837366e510e5cc53f7081e3a92b2c0962281d88453c5cfc65d837a2439b096fd3b517182d02f0507deca4cf694d80736d8192479a91b WHIRLPOOL 8decf4dc0b4c1101f87444ac8f43f35db916752635a8a61daf4e63a7bb57104cdfc3c5de3d41f062b840d314908f21328eebaf4a5cdb37876fb379000704b1d0
diff --git a/dev-ruby/activeldap/activeldap-3.2.2.ebuild b/dev-ruby/activeldap/activeldap-3.2.2.ebuild
new file mode 100644
index 000000000000..ff4729accfb5
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-3.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_bdepend "dev-ruby/hoe"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-3.2.8:3.2
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
diff --git a/dev-ruby/activeldap/activeldap-4.0.4.ebuild b/dev-ruby/activeldap/activeldap-4.0.4.ebuild
new file mode 100644
index 000000000000..dc1d41077fad
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-4.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-4.0.0:4.0
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
diff --git a/dev-ruby/activeldap/metadata.xml b/dev-ruby/activeldap/metadata.xml
new file mode 100644
index 000000000000..cfce92669cd9
--- /dev/null
+++ b/dev-ruby/activeldap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">activeldap/activeldap</remote-id>
+ </upstream>
+</pkgmetadata>