summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ammeter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ammeter')
-rw-r--r--dev-ruby/ammeter/Manifest1
-rw-r--r--dev-ruby/ammeter/ammeter-1.1.2.ebuild72
-rw-r--r--dev-ruby/ammeter/metadata.xml8
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-ruby/ammeter/Manifest b/dev-ruby/ammeter/Manifest
new file mode 100644
index 000000000000..b0cd0b49f4a2
--- /dev/null
+++ b/dev-ruby/ammeter/Manifest
@@ -0,0 +1 @@
+DIST ammeter-1.1.2.gem 18432 SHA256 99c55552b25ad39598b7f45d24fa849853cff4abcef235d35fa6f8ffd427b1d5 SHA512 af723c7e4111862678902dfdba734b34c9893b6cd5a8dab754c24b41baf672bafab1044a2928f61d5078e82055ccfe2c05a060b1f8e4f4da164147ffd8241f6a WHIRLPOOL 21b38bf2a1781f664761e5c822ca1ab6c8346d6020b863cdbff3ed0238a618989aa66b2642207b8a3deee74fb6d521169a397ebc10a41e4b4a2d6cf06baf8c8c
diff --git a/dev-ruby/ammeter/ammeter-1.1.2.ebuild b/dev-ruby/ammeter/ammeter-1.1.2.ebuild
new file mode 100644
index 000000000000..8278e4dfd8b6
--- /dev/null
+++ b/dev-ruby/ammeter/ammeter-1.1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Write specs for your Rails 3+ generators"
+HOMEPAGE="https://github.com/alexrothenberg/ammeter"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Restrict tests since they now require the specific rspec version to be
+# provided in an environment variable.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-3.0
+ >=dev-ruby/railties-3.0
+ >=dev-ruby/rspec-rails-2.2
+"
+
+# ruby_add_bdepend "
+# test? (
+# >=dev-ruby/rails-3.1
+# <dev-ruby/rails-4.1
+# dev-ruby/uglifier
+# dev-ruby/rake
+# dev-ruby/coffee-rails
+# dev-ruby/sass-rails
+# dev-ruby/jquery-rails
+# dev-util/cucumber
+# dev-util/aruba
+# dev-ruby/sqlite3
+# dev-ruby/bundler
+# )"
+
+all_ruby_prepare() {
+ # fix the gemspec; we remove the version dependencies from there, as
+ # it requires _older_ versions of its dependencies.. it doesn't
+ # really seem to be the case though. Also remove the references to
+ # git ls-files to avoid calling it.
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/\(cucumber\|aruba\)/s:,.*$::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Specs are not compatible with Rails 4.1
+ sed -i -e '23i s.add_development_dependency "rails", "<4.1"' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid spec that returns a different but valid response on ruby21
+ sed -e '/when the file is not there/,/^ end/ s:^:#:' -i spec/ammeter/rspec/generator/matchers/contain_spec.rb || die
+
+ # haml-rails is not packaged
+ sed -i -e '/haml-rails/d' ${RUBY_FAKEGEM_GEMSPEC} Gemfile || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3.1.0 ${RUBY} -S bundle exec ${RUBY} -S rspec-3 spec || die
+}
diff --git a/dev-ruby/ammeter/metadata.xml b/dev-ruby/ammeter/metadata.xml
new file mode 100644
index 000000000000..9a04f42106bd
--- /dev/null
+++ b/dev-ruby/ammeter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">alexrothenberg/ammeter</remote-id>
+ </upstream>
+</pkgmetadata>