summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/binding_of_caller
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/binding_of_caller')
-rw-r--r--dev-ruby/binding_of_caller/Manifest1
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.7.2.ebuild27
-rw-r--r--dev-ruby/binding_of_caller/metadata.xml8
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/Manifest b/dev-ruby/binding_of_caller/Manifest
new file mode 100644
index 000000000000..4c7382e3a356
--- /dev/null
+++ b/dev-ruby/binding_of_caller/Manifest
@@ -0,0 +1 @@
+DIST binding_of_caller-0.7.2.gem 85504 SHA256 d327682ce1d8e8cc46e282a46052946af0de16bef734014c63df0aac66334f96 SHA512 6eb114070c3f15801c4f2454433630c207c2fb93afcf5906fa1288985303ff87c54ca07273b623bc2d3f76dc5bf363feb1561e109f599776a785aab65dfd7132 WHIRLPOOL 1ccfe6389e0a62730015e2e9bc3b0c20278e9175411561ab913225179e2bc37e58b66aa45cdd8fac32ec67c68a7838471a92140ffe1eb0be5a419b9a551721db
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.7.2.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.7.2.ebuild
new file mode 100644
index 000000000000..b3176d244cb8
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -rubygems -a -q || die
+}
diff --git a/dev-ruby/binding_of_caller/metadata.xml b/dev-ruby/binding_of_caller/metadata.xml
new file mode 100644
index 000000000000..337647c7094a
--- /dev/null
+++ b/dev-ruby/binding_of_caller/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">banister/binding_of_caller</remote-id>
+ </upstream>
+</pkgmetadata>