summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-04 08:16:55 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-05 07:51:06 +0100
commit05aa0a1c4d7dc547b122181d0d816860d19c8f45 (patch)
treef7db009128e1159b73b95e77dbc0ecf188356a82 /dev-ruby/concurrent-ruby
parentwww-client/opera: Old. (diff)
downloadgentoo-05aa0a1c4d7dc547b122181d0d816860d19c8f45.tar.gz
gentoo-05aa0a1c4d7dc547b122181d0d816860d19c8f45.tar.bz2
gentoo-05aa0a1c4d7dc547b122181d0d816860d19c8f45.zip
dev-ruby/concurrent-ruby: initial import of 1.0.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/concurrent-ruby')
-rw-r--r--dev-ruby/concurrent-ruby/Manifest1
-rw-r--r--dev-ruby/concurrent-ruby/concurrent-ruby-1.0.0.ebuild36
-rw-r--r--dev-ruby/concurrent-ruby/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/concurrent-ruby/Manifest b/dev-ruby/concurrent-ruby/Manifest
new file mode 100644
index 000000000000..f92198a739cb
--- /dev/null
+++ b/dev-ruby/concurrent-ruby/Manifest
@@ -0,0 +1 @@
+DIST concurrent-ruby-1.0.0.tar.gz 1269980 SHA256 21a5942bd18d6ca2bdf547f16925f167b0c18592f737091ea5531f07de92fba0 SHA512 5b2a6b5d0e43d1df768d9e18328ecee04796af70edaa72646431e0c4e2ff75387542cce8f78b69d73514166348ed73f906f00bd6e627969159ab1ce4e2a75e6c WHIRLPOOL c7875df7f5c3f91487c1a85a46948225ccfebeb625ae1d4c6fd5b87ba7f224bc50aeb782a58bcfd6f5423d52dea7a54ef57189ae0bc4a23b5996e0b9b41feede
diff --git a/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.0.ebuild b/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.0.ebuild
new file mode 100644
index 000000000000..6fe323ef0095
--- /dev/null
+++ b/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Modern concurrency tools including agents, futures, promises, thread pools, more"
+HOMEPAGE="https://github.com/ruby-concurrency/concurrent-ruby"
+SRC_URI="https://github.com/ruby-concurrency/concurrent-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove edge files as defined in support/file_map.rb
+ rm -rf {lib,spec}/concurrent/{actor,channel,edge}* \
+ lib/concurrent/{concurrent-edge,lazy_register.rb} \
+ spec/concurrent/lazy_register_spec.rb || die
+ sed -i -e '/concurrent-edge/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove specs for the ext gem
+ rm -rf spec/concurrent/atomic || die
+
+ sed -i -e '/file_map/d' -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/concurrent-ruby/metadata.xml b/dev-ruby/concurrent-ruby/metadata.xml
new file mode 100644
index 000000000000..aedd3ca9cde7
--- /dev/null
+++ b/dev-ruby/concurrent-ruby/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-concurrency/concurrent-ruby</remote-id>
+ </upstream>
+</pkgmetadata>