summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-11 08:00:27 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-11 08:00:27 +0100
commit8b6929eeba50126978a43ac18bdbf559bf5a2d5a (patch)
treefeb76beb6f746486fc817fe16680a5bbfaaab2f0 /dev-ruby/daemons/daemons-1.3.0.ebuild
parentx11-terms/alacritty: rust-1.31.0 is required for 0.2.4 (diff)
downloadgentoo-8b6929eeba50126978a43ac18bdbf559bf5a2d5a.tar.gz
gentoo-8b6929eeba50126978a43ac18bdbf559bf5a2d5a.tar.bz2
gentoo-8b6929eeba50126978a43ac18bdbf559bf5a2d5a.zip
dev-ruby/daemons: add 1.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/daemons/daemons-1.3.0.ebuild')
-rw-r--r--dev-ruby/daemons/daemons-1.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/daemons/daemons-1.3.0.ebuild b/dev-ruby/daemons/daemons-1.3.0.ebuild
new file mode 100644
index 000000000000..c11106d3dddc
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}