summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/daemons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/daemons')
-rw-r--r--dev-ruby/daemons/Manifest3
-rw-r--r--dev-ruby/daemons/daemons-1.1.9-r1.ebuild37
-rw-r--r--dev-ruby/daemons/daemons-1.2.2.ebuild30
-rw-r--r--dev-ruby/daemons/daemons-1.2.3.ebuild30
-rw-r--r--dev-ruby/daemons/metadata.xml8
5 files changed, 108 insertions, 0 deletions
diff --git a/dev-ruby/daemons/Manifest b/dev-ruby/daemons/Manifest
new file mode 100644
index 000000000000..459d0fa8f573
--- /dev/null
+++ b/dev-ruby/daemons/Manifest
@@ -0,0 +1,3 @@
+DIST daemons-1.1.9.gem 32768 SHA256 fee738586059ac5051ed89b40b63d02bdc9a19254f9b6e58848dea1c2f3135c8 SHA512 7f29162c7cb728ae27dbd16a9bc5191bb617b6cfacd1c698d2bbe43d335224b1ad59eea36205331abb9b3586c454e584333c6464f5afc033c48e676db6983f45 WHIRLPOOL 9335fde9642212f499449da75ae664443647f7a03622e75b8e71151b5db9d054ebb3d7c499ef734abb6b313543b5a6563a53412a7d2efdf5c2a3460703878e64
+DIST daemons-1.2.2.gem 24576 SHA256 c3b2d10a8c700b144bc47eb58d7b9d1ce1d8f96cbb27a35e576bbc1ae73e2c88 SHA512 771e9d09f305cacede9337b15e4b55474549f512c0f004aebea8630d1b4c77f3e8486644c569b65bd8137161e71171c48a34a7807ad53bfce6bacc8d1596466e WHIRLPOOL a328b8095f093d94078b51f7f34c3f1fd431def937d92e45a4a2d6cb8d79b82e4b930fc62697b754099b688a546bd306396c37d291860a83bba2556c98dd1241
+DIST daemons-1.2.3.gem 24576 SHA256 0fbf1f7ef654e98fac324b43ab690576fbe8b66941693b473f4f27ef334c032d SHA512 05acecc07bc3f760472453dd11eb0231b9e7f2e04a783ab44dacecf9c666d01122d27fdb782d9973f475bc378e0e3e51795ad58e221f29b201b1ba5e0de1e277 WHIRLPOOL 9568c383912195964b0079df60f8342268a51d75c0251b50e5c747759b82463d3d79a597e593a24ee84eb8618a637bcb22cb842b7c9a43d67db1f0be41c72e5c
diff --git a/dev-ruby/daemons/daemons-1.1.9-r1.ebuild b/dev-ruby/daemons/daemons-1.1.9-r1.ebuild
new file mode 100644
index 000000000000..71e9bab85f89
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.9-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -e '/gempackagetask/ s:^:#:' \
+ -e '/GemPackageTask/,/end/ s:^:#:' \
+ -e 's:rake/rdoctask:rdoc/task:' \
+ -i Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}
diff --git a/dev-ruby/daemons/daemons-1.2.2.ebuild b/dev-ruby/daemons/daemons-1.2.2.ebuild
new file mode 100644
index 000000000000..963e01e376a0
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}
diff --git a/dev-ruby/daemons/daemons-1.2.3.ebuild b/dev-ruby/daemons/daemons-1.2.3.ebuild
new file mode 100644
index 000000000000..963e01e376a0
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}
diff --git a/dev-ruby/daemons/metadata.xml b/dev-ruby/daemons/metadata.xml
new file mode 100644
index 000000000000..6579fc77631b
--- /dev/null
+++ b/dev-ruby/daemons/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">thuehlinger/daemons</remote-id>
+ </upstream>
+</pkgmetadata>