summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/execjs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/execjs')
-rw-r--r--dev-ruby/execjs/Manifest3
-rw-r--r--dev-ruby/execjs/execjs-1.4.0.ebuild46
-rw-r--r--dev-ruby/execjs/execjs-2.2.2.ebuild40
-rw-r--r--dev-ruby/execjs/execjs-2.5.2.ebuild41
-rw-r--r--dev-ruby/execjs/metadata.xml8
5 files changed, 138 insertions, 0 deletions
diff --git a/dev-ruby/execjs/Manifest b/dev-ruby/execjs/Manifest
new file mode 100644
index 000000000000..5d6b548a6ba0
--- /dev/null
+++ b/dev-ruby/execjs/Manifest
@@ -0,0 +1,3 @@
+DIST execjs-1.4.0-git.tgz 14300 SHA256 76f10e338cfc0e79cb25110db97d6813f6dcce035daa19f66101188607069cfb SHA512 ed41db6f1c95be7bf5b379370c2f06894a0a233aaceeadf45172c0cfa1ab84f4eac7cb91608d02888c35f1dc9355f1fce60a5779535db58066ff1dacab6e0be8 WHIRLPOOL 226db6a8598735ae75ecfb11b2a03f61a75c6f191fe2d3abee3b57c8d76a284d160e3cb7359499ce4af8f9affc88b8d6b8c1499114e8fc28f55271e8266dbfc6
+DIST execjs-2.2.2.tar.gz 64585 SHA256 6290e0d10152fe9a0962e7b001d27566a65d620c01fc0378bdd4b343ac671026 SHA512 3887c70bcdf334ae1ebdbdd6a96fc11b4fcab3f3a41883cc086854cf8f0973f7f020ef624476ab844dd4c14fb79a93ab8701099a124695643ff2c4c5802ed3db WHIRLPOOL 0c76a5eae52b6f869801af03fbdb0ad337ba5d8ba6b018c217201c93e444fdb8b01d6ee2ed41d6a0528567aca22bbc1ea78e54dd403e77bb147767adca6e6b31
+DIST execjs-2.5.2.tar.gz 423380 SHA256 21e9adf3eea692b48c38b609bb40159a5a1f476e067a5be859586784c9b98918 SHA512 bd923e75665e36b250ea769938de579c5dbdcea52764d55127fa37967e1b44a368f86871d0d107f25d6161ec5ec83255675fd8cb43f68d58e27282eec69995e3 WHIRLPOOL 8da83f1536019dc439ced1cca156afead0d176ae07348aaec32f9726ccccd5afcc3a2a038c9fb574a833d68dc75ded1590825963dcc4643ca1e051ea7c7914f6
diff --git a/dev-ruby/execjs/execjs-1.4.0.ebuild b/dev-ruby/execjs/execjs-1.4.0.ebuild
new file mode 100644
index 000000000000..91a5462afbc9
--- /dev/null
+++ b/dev-ruby/execjs/execjs-1.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="sstephenson"
+GITHUB_PROJECT="${PN}"
+RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND="${RDEPEND} || ( net-libs/nodejs )"
+
+all_ruby_prepare() {
+ # Network access
+ sed -i -e "/test_coffeescript/,+5d" test/test_execjs.rb || die
+}
diff --git a/dev-ruby/execjs/execjs-2.2.2.ebuild b/dev-ruby/execjs/execjs-2.2.2.ebuild
new file mode 100644
index 000000000000..0478c4ee851f
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND+=" || ( net-libs/nodejs )"
+
+all_ruby_prepare() {
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}
diff --git a/dev-ruby/execjs/execjs-2.5.2.ebuild b/dev-ruby/execjs/execjs-2.5.2.ebuild
new file mode 100644
index 000000000000..16313f343ac4
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/rails/execjs"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND+=" || ( net-libs/nodejs )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}
diff --git a/dev-ruby/execjs/metadata.xml b/dev-ruby/execjs/metadata.xml
new file mode 100644
index 000000000000..0126fe7b8326
--- /dev/null
+++ b/dev-ruby/execjs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/execjs</remote-id>
+ </upstream>
+</pkgmetadata>