summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-25 07:04:20 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-25 07:23:05 +0200
commitef167d9e38fea2023247714b45bd48ae6289da1e (patch)
treee88c88328e3f427229f568e52a532866ce48b026 /dev-ruby/fakeweb
parentnet-irc/quassel: Remove 0.12.4-r1 (diff)
downloadgentoo-ef167d9e38fea2023247714b45bd48ae6289da1e.tar.gz
gentoo-ef167d9e38fea2023247714b45bd48ae6289da1e.tar.bz2
gentoo-ef167d9e38fea2023247714b45bd48ae6289da1e.zip
dev-ruby/fakeweb: add new snapshot for ruby24, ruby25 support
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/fakeweb')
-rw-r--r--dev-ruby/fakeweb/Manifest1
-rw-r--r--dev-ruby/fakeweb/fakeweb-1.3.0.20170806.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/fakeweb/Manifest b/dev-ruby/fakeweb/Manifest
index 7f863e9e0873..a2fd4256c697 100644
--- a/dev-ruby/fakeweb/Manifest
+++ b/dev-ruby/fakeweb/Manifest
@@ -1 +1,2 @@
DIST fakeweb-1.3.0.20131201.tar.gz 60162 BLAKE2B 856c499041b122d84fde595343e0917a9ac47e81e50560be79a53def2099ea0ad05532bf3a7e3cd5e8dc668235c1ee75989b15465f397f56b7c0edd028bf980c SHA512 f3bd40680b7eefe90d3fee67f5282dbe4c67d46a1f1040d0d0d62c978b69d08987581a53495bb56e32ebcc6679c84f03c2e26c51d2bd98daa80554d3424c6603
+DIST fakeweb-1.3.0.20170806.tar.gz 61449 BLAKE2B f015f95897383e0b65ada5a7833f7bd3fd61ae77f4ab38bf6bb47f2eecef0c778928090302e46157ae4e2fc6c3df4559e9f5c8004a6474ad8852d157aa3af6da SHA512 1871b7c9f2e4f12cd1c434ef4f760828187078a951517fe3f7a6ca5c5d6f08e3056cae2bb012eca1ba556c2f4d369cb2716c637fefee67eb723428195c482edf
diff --git a/dev-ruby/fakeweb/fakeweb-1.3.0.20170806.ebuild b/dev-ruby/fakeweb/fakeweb-1.3.0.20170806.ebuild
new file mode 100644
index 000000000000..8c53e00193b5
--- /dev/null
+++ b/dev-ruby/fakeweb/fakeweb-1.3.0.20170806.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+COMMIT=2b08c1ff2714ec13a12f3497d67fcefce95c2cbe
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper for faking web requests in Ruby"
+HOMEPAGE="https://github.com/chrisk/fakeweb"
+SRC_URI="https://github.com/chrisk/fakeweb/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/test-unit
+ )"
+
+all_ruby_prepare() {
+ # The package bundles samuel and right_http_connection, remove
+ # them
+ rm -r test/vendor || die "failed to remove bundled gems"
+
+ # We don't package sdoc and we don't have the direct template.
+ sed -i -e 's/sdoc/rdoc/' -e '/template/d' Rakefile || die
+
+ # Use the test-unit gem to make jruby compatible with newer mocha.
+ sed -i -e '1igem "test-unit"' \
+ -e '/bundler/I s:^:#:' \
+ -e '/simplecov/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid test dependencies on unmaintained packages that no longer work
+ rm test/test_other_net_http_libraries.rb || die
+
+ sed -i -e '/test:preflight/ s:^:#:' Rakefile || die
+}