summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/haml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/Manifest1
-rw-r--r--dev-ruby/haml/files/haml-3.1.6-sass.patch20
-rw-r--r--dev-ruby/haml/haml-4.0.6-r1.ebuild51
-rw-r--r--dev-ruby/haml/haml-4.0.6.ebuild51
-rw-r--r--dev-ruby/haml/metadata.xml5
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-ruby/haml/Manifest b/dev-ruby/haml/Manifest
new file mode 100644
index 000000000000..924a8b5ac500
--- /dev/null
+++ b/dev-ruby/haml/Manifest
@@ -0,0 +1 @@
+DIST haml-4.0.6.gem 115712 SHA256 2ede5f8a1f38d98e71daf570d836ec0db18e1c6187c383a50fb7eb2223beff23 SHA512 a58d3de9efb6ac80a504152a4ca71914681a334d802301c9c8954890e97b031d771f4ac5127713d5e1c1e051d6c74fb7c9d55b6b6e7166743e95ed33685be1c4 WHIRLPOOL 0b821983baa267ae03dee990b2432562601af4fe2c84d4f8f9a46133817470c97baef47098ed78f714b9eda5dae75d4cba4a8059398d9f9acf018633a713e4ab
diff --git a/dev-ruby/haml/files/haml-3.1.6-sass.patch b/dev-ruby/haml/files/haml-3.1.6-sass.patch
new file mode 100644
index 000000000000..386854840d8e
--- /dev/null
+++ b/dev-ruby/haml/files/haml-3.1.6-sass.patch
@@ -0,0 +1,20 @@
+--- metadata.orig 2012-07-03 07:46:35.000000000 +0200
++++ metadata 2012-07-03 07:51:30.917926913 +0200
+@@ -14,6 +14,17 @@
+ date: 2012-05-16 00:00:00.000000000 Z
+ dependencies:
+ - !ruby/object:Gem::Dependency
++ name: sass
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ version: 3.2.0
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
+ name: yard
+ requirement: !ruby/object:Gem::Requirement
+ none: false
diff --git a/dev-ruby/haml/haml-4.0.6-r1.ebuild b/dev-ruby/haml/haml-4.0.6-r1.ebuild
new file mode 100644
index 000000000000..d0276311c36f
--- /dev/null
+++ b/dev-ruby/haml/haml-4.0.6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+
+ruby_add_rdepend "dev-ruby/tilt"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ dev-ruby/rails:4.2
+ )
+ doc? (
+ dev-ruby/yard
+ >=dev-ruby/maruku-0.7.2-r1
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 's/gem "minitest"/gem "minitest", "~>5.0"/'\
+ -e '1igem "actionpack", "~>4.2"'\
+ -e '1igem "activesupport", "~>4.2"'\
+ -e '1igem "railties", "~>4.2"'\
+ test/test_helper.rb || die
+ # Remove test that fails when RedCloth is available
+ sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,+9 s/^/#/"\
+ test/filters_test.rb || die
+}
diff --git a/dev-ruby/haml/haml-4.0.6.ebuild b/dev-ruby/haml/haml-4.0.6.ebuild
new file mode 100644
index 000000000000..24181ee30e68
--- /dev/null
+++ b/dev-ruby/haml/haml-4.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+
+ruby_add_rdepend "dev-ruby/tilt"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:0
+ dev-ruby/nokogiri
+ dev-ruby/rails:3.2
+ )
+ doc? (
+ dev-ruby/yard
+ >=dev-ruby/maruku-0.7.2-r1
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 's/gem "minitest"/gem "minitest", "~>4.0"/'\
+ -e '1igem "actionpack", "~>3.2"'\
+ -e '1igem "activesupport", "~>3.2"'\
+ -e '1igem "railties", "~>3.2"'\
+ test/test_helper.rb || die
+ # Remove test that fails when RedCloth is available
+ sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,+9 s/^/#/"\
+ test/filters_test.rb || die
+}
diff --git a/dev-ruby/haml/metadata.xml b/dev-ruby/haml/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/haml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>