summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/highline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/highline')
-rw-r--r--dev-ruby/highline/Manifest4
-rw-r--r--dev-ruby/highline/highline-1.6.21.ebuild40
-rw-r--r--dev-ruby/highline/highline-1.7.1.ebuild40
-rw-r--r--dev-ruby/highline/highline-1.7.2.ebuild40
-rw-r--r--dev-ruby/highline/highline-1.7.3.ebuild40
-rw-r--r--dev-ruby/highline/metadata.xml8
6 files changed, 172 insertions, 0 deletions
diff --git a/dev-ruby/highline/Manifest b/dev-ruby/highline/Manifest
new file mode 100644
index 000000000000..9383db3e448a
--- /dev/null
+++ b/dev-ruby/highline/Manifest
@@ -0,0 +1,4 @@
+DIST highline-1.6.21.gem 221184 SHA256 c136298eee86ceff87baadc71d764ea07986f89805636e4a6a305b2d5da07519 SHA512 520f319816453a576ed14294d38bbace80c6a70d79c5500eca47e612449b7b5c99d5d28f401457e981a2b511cbd28a8fdf6f3e1dd30113aff59f134ae89d1111 WHIRLPOOL 14289aef26079419f6f93c88cc022bd830c848c438b6958e9c52a59c8d5ce760633fba5007a651c17770ea4e69c354d3c119c2c97c11b4dad95bcf101cab22c1
+DIST highline-1.7.1.gem 224256 SHA256 d99d40a65ea24b10e38629ccae6ab1ef466ddb3fde829b09c16a995ab9fba58c SHA512 b642c953005fb21ceef76eb5c4642b1ee8d2072ef3fea7e210d4ca12414deaad4d1323f4442f9653b54144c22a7046d5b190a776738ba06dac758bd956d50e44 WHIRLPOOL 030c9eec354634b63e0329aae9bc98ac6b5d9eee2c0b2e731732d4822db27d278a2aea06b73759539ad6b4d642a599ecdd618001e8bbb267affa5a48d3165ec3
+DIST highline-1.7.2.gem 224256 SHA256 5beef0869e444075e701ffd87f47a9ebc6beb4c417976425d454d2775bdf9d91 SHA512 a53e3b5685c85b6e6a890747b95bede695cd8fed0fa3b0b43eafe2337f35f0cf846fae1fe684ac59649f95f7da422dcb30100fd46eb05ade4bdd8362cd697f0a WHIRLPOOL 05c6c8e05004c70b7fe827e7760a2ce447297c69f7c322d6842cb0c46a8b28b8506c494308bf15cfc58abfae64fa0dc1ad4f1bfa990360bed5d723dec4d80165
+DIST highline-1.7.3.gem 224256 SHA256 d2f7b7bf88499a156130e40038d0b3046e1da20fd8eece46a31577a533ab2d0d SHA512 29cd6a2d77529b9c54b16cdd01866d5d779189633f39d1a3f8f36bac940e034c6073563f831d733b30a5280527f86ad6116508d6c8261af7ea09173aa5093151 WHIRLPOOL f74ce3ffe79db0553245f145c76ddf8d5438a699e7b4cd9ce2135a0738fe1fa2a45ca8ddf7fbd6e14fc3948717bcdb9c395658c968388af1f0dccc61325d5fd0
diff --git a/dev-ruby/highline/highline-1.6.21.ebuild b/dev-ruby/highline/highline-1.6.21.ebuild
new file mode 100644
index 000000000000..04ce912410ac
--- /dev/null
+++ b/dev-ruby/highline/highline-1.6.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="http://highline.rubyforge.org/"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ sed -i -e '/tc_highline/ s:^:#:' test/ts_all.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake test || die
+}
diff --git a/dev-ruby/highline/highline-1.7.1.ebuild b/dev-ruby/highline/highline-1.7.1.ebuild
new file mode 100644
index 000000000000..07bc7fc67114
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}
diff --git a/dev-ruby/highline/highline-1.7.2.ebuild b/dev-ruby/highline/highline-1.7.2.ebuild
new file mode 100644
index 000000000000..07bc7fc67114
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}
diff --git a/dev-ruby/highline/highline-1.7.3.ebuild b/dev-ruby/highline/highline-1.7.3.ebuild
new file mode 100644
index 000000000000..07bc7fc67114
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}
diff --git a/dev-ruby/highline/metadata.xml b/dev-ruby/highline/metadata.xml
new file mode 100644
index 000000000000..45266ec88a75
--- /dev/null
+++ b/dev-ruby/highline/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">JEG2/highline</remote-id>
+ </upstream>
+</pkgmetadata>