summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/journey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/journey')
-rw-r--r--dev-ruby/journey/Manifest1
-rw-r--r--dev-ruby/journey/files/journey-1.0.4-fix-tests.patch66
-rw-r--r--dev-ruby/journey/journey-1.0.4-r1.ebuild28
-rw-r--r--dev-ruby/journey/metadata.xml8
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-ruby/journey/Manifest b/dev-ruby/journey/Manifest
new file mode 100644
index 000000000000..3fdcf0cc2b3d
--- /dev/null
+++ b/dev-ruby/journey/Manifest
@@ -0,0 +1 @@
+DIST journey-1.0.4.gem 28672 SHA256 7454b8612530784000fbb17ea2df749a71b70702a0ac8ebef4a1e7f05aecc10f SHA512 9e6a06da8b77f6efb9941c58f53254e8cf3a1ebb6f8261a66ef3fed9c21ff4e4a90567fee88507b8e2c1fecc0fbdf204a9d3c8473b671bbb4b8c6b9faa6f2a07 WHIRLPOOL 1fb1ff42d1cd401ad10dc22e8d705933d8ff5fc84f952e3fbf0e2ea77b0ecc4ac08280ee5e2bd23b3cbeb4729e23b2c5ca41f3ce49deb898033073dc7be418b1
diff --git a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
new file mode 100644
index 000000000000..f977172e6464
--- /dev/null
+++ b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
@@ -0,0 +1,66 @@
+From d836e960d9a20c4c5bc986630d2ba34a340959ea Mon Sep 17 00:00:00 2001
+From: Aaron Patterson <aaron.patterson@gmail.com>
+Date: Fri, 27 Jul 2012 11:20:58 -0700
+Subject: [PATCH] fix assertion calls
+
+---
+ test/path/test_pattern.rb | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/test/path/test_pattern.rb b/test/path/test_pattern.rb
+index c684a0a..ec93471 100644
+--- a/test/path/test_pattern.rb
++++ b/test/path/test_pattern.rb
+@@ -85,9 +85,9 @@ def test_to_regexp_with_extended_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/tender', path)
+- assert_match('/page/love', path)
+- refute_match('/page/loving', path)
++ assert_match(path, '/page/tender')
++ assert_match(path, '/page/love')
++ refute_match(path, '/page/loving')
+ end
+
+ def test_optional_names
+@@ -108,8 +108,8 @@ def test_to_regexp_match_non_optional
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/123', path)
+- refute_match('/', path)
++ assert_match(path, '/123')
++ refute_match(path, '/')
+ end
+
+ def test_to_regexp_with_group
+@@ -119,9 +119,9 @@ def test_to_regexp_with_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/tender', path)
+- assert_match('/page/love', path)
+- refute_match('/page/loving', path)
++ assert_match(path, '/page/tender')
++ assert_match(path, '/page/love')
++ refute_match(path, '/page/loving')
+ end
+
+ def test_ast_sets_regular_expressions
+@@ -186,9 +186,9 @@ def test_insensitive_regexp_with_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/TENDER/aaron', path)
+- assert_match('/page/loVE/aaron', path)
+- refute_match('/page/loVE/AAron', path)
++ assert_match(path, '/page/TENDER/aaron')
++ assert_match(path, '/page/loVE/aaron')
++ refute_match(path, '/page/loVE/AAron')
+ end
+
+ def test_to_regexp_with_strexp
+--
+1.9.1
+
diff --git a/dev-ruby/journey/journey-1.0.4-r1.ebuild b/dev-ruby/journey/journey-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..fd68cb746419
--- /dev/null
+++ b/dev-ruby/journey/journey-1.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Journey is a router. It routes requests"
+HOMEPAGE="https://github.com/rails/journey"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe
+ dev-ruby/json
+ dev-ruby/minitest )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
diff --git a/dev-ruby/journey/metadata.xml b/dev-ruby/journey/metadata.xml
new file mode 100644
index 000000000000..ae09d2af7185
--- /dev/null
+++ b/dev-ruby/journey/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/journey</remote-id>
+ </upstream>
+</pkgmetadata>