summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-14 20:54:01 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-14 21:42:00 +0200
commit6a97aab53566516854a609ad550039f8593698b6 (patch)
treea818bc19d3c2b37324d0f2cd2e0bca39822f66e6 /dev-ruby/json
parentdev-ruby/hiera: add ruby22 (diff)
downloadgentoo-6a97aab53566516854a609ad550039f8593698b6.tar.gz
gentoo-6a97aab53566516854a609ad550039f8593698b6.tar.bz2
gentoo-6a97aab53566516854a609ad550039f8593698b6.zip
dev-ruby/json: add ruby22
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/json-1.8.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/json/json-1.8.2-r1.ebuild b/dev-ruby/json/json-1.8.2-r1.ebuild
index a7de3ac62337..e15a6827e7db 100644
--- a/dev-ruby/json/json-1.8.2-r1.ebuild
+++ b/dev-ruby/json/json-1.8.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
@@ -52,11 +52,11 @@ each_ruby_compile() {
each_ruby_test() {
JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "pure ruby tests failed"
if [[ $(basename ${RUBY}) != "jruby" ]]; then
JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "ext ruby tests failed"
fi
}