summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-03 19:37:10 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-03 19:39:00 +0200
commit7906c9cef4b3c4809cf9921e0a725152791337e2 (patch)
treed55d98b1604a9acb3b7235f9ab9add5aa1928ef3 /dev-ruby/logue/logue-1.0.13-r1.ebuild
parentapp-crypt/mit-krb5: s390 stable wrt bug #615396 (diff)
downloadgentoo-7906c9cef4b3c4809cf9921e0a725152791337e2.tar.gz
gentoo-7906c9cef4b3c4809cf9921e0a725152791337e2.tar.bz2
gentoo-7906c9cef4b3c4809cf9921e0a725152791337e2.zip
dev-ruby/logue: add missing test dependency on paramesan, bug 657286
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/logue/logue-1.0.13-r1.ebuild')
-rw-r--r--dev-ruby/logue/logue-1.0.13-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/logue/logue-1.0.13-r1.ebuild b/dev-ruby/logue/logue-1.0.13-r1.ebuild
new file mode 100644
index 000000000000..1d823a3b3102
--- /dev/null
+++ b/dev-ruby/logue/logue-1.0.13-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module that adds logging/trace functionality"
+HOMEPAGE="https://github.com/jpace/logue"
+
+SRC_URI="https://github.com/jpace/logue/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rainbow:3"
+
+ruby_add_bdepend "test? ( dev-ruby/paramesan )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix path to match installed gem path
+ sed -i -e 's:logue/lib/logue:/lib/logue:' lib/logue/stack.rb || die
+}