summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-12 17:26:42 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-12 17:26:56 +0100
commit65b139f4f5393ea19b637caceb0578e70a7b3e0b (patch)
treecd14eccc4adfa2b643d7feece4118fc68232ee3c /dev-ruby/loofah
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-65b139f4f5393ea19b637caceb0578e70a7b3e0b.tar.gz
gentoo-65b139f4f5393ea19b637caceb0578e70a7b3e0b.tar.bz2
gentoo-65b139f4f5393ea19b637caceb0578e70a7b3e0b.zip
Revert "dev-ruby/loofah: cleanup"
This reverts commit abeea1055596cfa1f1a4da74e80b8a40e3e10c7a. This cleanup removed the last keyworded ebuild of dev-ruby/loofah for arm which is is still required for arm-keyworded dev-ruby/rails-html-sanitizer. Cleanup has to be postponed until [Bug 631974] is resolved. Bug: https://bugs.gentoo.org/631974
Diffstat (limited to 'dev-ruby/loofah')
-rw-r--r--dev-ruby/loofah/Manifest1
-rw-r--r--dev-ruby/loofah/loofah-2.0.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/loofah/Manifest b/dev-ruby/loofah/Manifest
index 8cdcf2e32341..79c0ec958a26 100644
--- a/dev-ruby/loofah/Manifest
+++ b/dev-ruby/loofah/Manifest
@@ -1 +1,2 @@
+DIST loofah-2.0.3.gem 60416 BLAKE2B 04e37464ac9e2b61fcc838763b6360fe80a8aeec26cc365803e6121bb4a628f17e79bc2426d0b351935dffc18829ab9d37239786fb3192c328f5a8026365cc41 SHA512 1f08bcfa09bf075b4d84707099cce6bdaa986cd6c79f63fc60c8bee4812c5a31cee1021cd314fc2033842d7b01ffe63f5f6acbf271a0db2ee631cd326520d700
DIST loofah-2.1.1.gem 61440 BLAKE2B adefeb040e0ad6302de3cfdd169cf33c22eb409be519f2acd610d210254295a935a8fc1223200003c27275756c8a3c604fb3c5589e3abc7c5207b457dcc6c349 SHA512 16499113ba3b435ba2cd3a583ed958db7f02604a56d87125341d5c143602ed9755272598faef9995be57f2b408c4696675f69cf5fb15d472c958e16f46c35d58
diff --git a/dev-ruby/loofah/loofah-2.0.3.ebuild b/dev-ruby/loofah/loofah-2.0.3.ebuild
new file mode 100644
index 000000000000..1aeea870ac75
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
+
+all_ruby_prepare() {
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+
+ # Fix test for new libxml2 results (fixed upstream)
+ sed -i -e '348i "xhtml": "&lt;&lt;script&gt;alert(\\\"XSS\\\");//&lt;&lt;/script&gt;",' test/assets/testdata_sanitizer_tests1.dat || die
+}