summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-10-21 10:27:54 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-10-21 10:30:29 -0400
commit44af6d0b938edf98025572e418a66cab2943e466 (patch)
treef83a91a8c5b183cc530d2dab2b4478d8c04aab37 /dev-ruby/metasm
parentUpdate remote-ids (diff)
downloadgentoo-44af6d0b938edf98025572e418a66cab2943e466.tar.gz
gentoo-44af6d0b938edf98025572e418a66cab2943e466.tar.bz2
gentoo-44af6d0b938edf98025572e418a66cab2943e466.zip
dev-ruby/metasm: fix deps and add missing || die
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ruby/metasm')
-rw-r--r--dev-ruby/metasm/metasm-1.0.2-r1.ebuild52
-rw-r--r--dev-ruby/metasm/metasm-1.0.2-r3.ebuild (renamed from dev-ruby/metasm/metasm-1.0.2-r2.ebuild)5
2 files changed, 1 insertions, 56 deletions
diff --git a/dev-ruby/metasm/metasm-1.0.2-r1.ebuild b/dev-ruby/metasm/metasm-1.0.2-r1.ebuild
deleted file mode 100644
index 8e6dc569c74..00000000000
--- a/dev-ruby/metasm/metasm-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRAINSTALL="metasm metasm.rb misc samples"
-
-DESCRIPTION="cross-architecture assembler, disassembler, linker, and debugger"
-HOMEPAGE="http://metasm.cr0.org/"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-LICENSE="BSD"
-SLOT="${PV}"
-KEYWORDS="~amd64 ~arm ~x86"
-#IUSE="development test"
-RESTRICT=test
-IUSE=""
-
-RDEPEND="${RDEPEND} !dev-ruby/metasploit-model:0"
-
-ruby_add_rdepend ">=dev-ruby/railties-4.0.9:4.0
- >=dev-ruby/activesupport-4.0.9:4.0
- >=dev-ruby/activemodel-4.0.9:4.0"
-ruby_add_bdepend "dev-ruby/bundler"
-
-all_ruby_prepare() {
- [ -f Gemfile.lock ] && rm Gemfile.lock
- #For now, we don't support development or testing at all
- #if ! use development; then
- sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
- sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
- sed -i -e "/spec.add_development_dependency/d" "${PN}".gemspec || die
- #fi
- #if ! use test; then
- sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
- #fi
- #if ! use test && ! use development; then
- sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
- #fi
-}
-
-each_ruby_prepare() {
- if [ -f Gemfile ]
- then
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
- fi
-}
diff --git a/dev-ruby/metasm/metasm-1.0.2-r2.ebuild b/dev-ruby/metasm/metasm-1.0.2-r3.ebuild
index 71d88884fff..ad7a2b57cbe 100644
--- a/dev-ruby/metasm/metasm-1.0.2-r2.ebuild
+++ b/dev-ruby/metasm/metasm-1.0.2-r3.ebuild
@@ -23,13 +23,10 @@ IUSE=""
RDEPEND="${RDEPEND} !dev-ruby/metasploit-model:0"
-ruby_add_rdepend ">=dev-ruby/railties-4.0.9:4.0
- >=dev-ruby/activesupport-4.0.9:4.0
- >=dev-ruby/activemodel-4.0.9:4.0"
ruby_add_bdepend "dev-ruby/bundler"
all_ruby_prepare() {
- [ -f Gemfile.lock ] && rm Gemfile.lock
+ [ -f Gemfile.lock ] && rm Gemfile.lock || die
#For now, we don't support development or testing at all
#if ! use development; then
sed -i -e "/^group :development do/,/^end$/d" Gemfile || die