summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:50 -0400
commit02bd428e62ca2cba9e41b923386b564283caa763 (patch)
tree32b4db545f0dc73d144a950f2a1383ec01375faf /dev-ruby/metasploit-model
parentnet-misc/dhcpcd: version bump (diff)
downloadgentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.gz
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.bz2
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.zip
net-analyzer/metasploit: add a modern version of metasploit (and a ton of deps for it)
Diffstat (limited to 'dev-ruby/metasploit-model')
-rw-r--r--dev-ruby/metasploit-model/Manifest1
-rw-r--r--dev-ruby/metasploit-model/metadata.xml14
-rw-r--r--dev-ruby/metasploit-model/metasploit-model-1.0.0.ebuild73
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-model/Manifest b/dev-ruby/metasploit-model/Manifest
new file mode 100644
index 000000000000..9c02535ff507
--- /dev/null
+++ b/dev-ruby/metasploit-model/Manifest
@@ -0,0 +1 @@
+DIST metasploit-model-1.0.0.gem 77312 SHA256 72e523dd4c13c6146a885599eae150b6addcc1b5e19165fd3382c5a783551cfe SHA512 1020b395787c6ad0f5b409c997f672e35e442e2499081dfab812a87c2aa8ff60d2b59ec1420e88b552e28c9ec12b420806475168da757e41e265d0b8df62dc39 WHIRLPOOL 5f211e16e3c383be0db5a66e97c95d7ff67831e1cfe980b325ff01d353094c69c47f245437ad354e4bd2b6293de288e751d39ead8e37f32242dde71a7b2c487e
diff --git a/dev-ruby/metasploit-model/metadata.xml b/dev-ruby/metasploit-model/metadata.xml
new file mode 100644
index 000000000000..a7eb21203ceb
--- /dev/null
+++ b/dev-ruby/metasploit-model/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+<longdescription lang="en">
+Common code, such as validators and mixins, that are shared between ActiveModels in metasploit-framework and ActiveRecords in metasploit_data_models
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/metasploit-model</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit-model/metasploit-model-1.0.0.ebuild b/dev-ruby/metasploit-model/metasploit-model-1.0.0.ebuild
new file mode 100644
index 000000000000..ef23f49ed1a1
--- /dev/null
+++ b/dev-ruby/metasploit-model/metasploit-model-1.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/metasploit_data_models/metasploit_data_models-0.17.0.ebuild,v 1.3 2014/07/09 21:13:54 zerochaos Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config script spec"
+
+DESCRIPTION="Common code, such as validators and mixins"
+HOMEPAGE="https://github.com/rapid7/metasploit-model"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+#IUSE="development test"
+RESTRICT=test
+IUSE=""
+
+RDEPEND="${RDEPEND} !dev-ruby/metasploit-model:0"
+
+ruby_add_rdepend ">=dev-ruby/railties-4.0.9:4.0
+ >=dev-ruby/activesupport-4.0.9:4.0
+ >=dev-ruby/activemodel-4.0.9:4.0"
+# development? ( dev-ruby/bundler
+# dev-ruby/rake
+# dev-ruby/i18n
+# dev-ruby/multi_json
+# dev-ruby/builder
+# dev-ruby/erubis
+# dev-ruby/journey
+# dev-ruby/rack
+# dev-ruby/rack-cache
+# dev-ruby/rack-test
+# dev-ruby/hike
+# dev-ruby/tilt
+# dev-ruby/sprockets:*
+# dev-ruby/actionpack:4.0
+# dev-ruby/json
+# dev-ruby/rack-ssl:*
+# dev-ruby/rdoc
+# dev-ruby/thor
+# dev-ruby/redcarpet
+# <dev-ruby/yard-0.8.7.4 )"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #For now, we don't support development or testing at all
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/spec.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]
+ then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}