summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-19 07:29:34 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-19 07:30:01 +0200
commit804334bc10c57525cb00edee9ec97b17271c9961 (patch)
tree6ae79c4b4bd5f2fab1d58c80d071c0e1379315a6 /dev-ruby/mime-types
parentdev-ruby/minitest-pretty_diff: add ruby23 (diff)
downloadgentoo-804334bc10c57525cb00edee9ec97b17271c9961.tar.gz
gentoo-804334bc10c57525cb00edee9ec97b17271c9961.tar.bz2
gentoo-804334bc10c57525cb00edee9ec97b17271c9961.zip
dev-ruby/mime-types: add missing dependency
Add missing runtime dependency on the mime data. This fixes part of bug 583304. Add missing test dependency and drop keywords accordingly, bug 583470. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/mime-types')
-rw-r--r--dev-ruby/mime-types/mime-types-3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/mime-types/mime-types-3.0-r1.ebuild b/dev-ruby/mime-types/mime-types-3.0-r1.ebuild
new file mode 100644
index 000000000000..79cbc4ed0177
--- /dev/null
+++ b/dev-ruby/mime-types/mime-types-3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a mailcap-like MIME Content-Type lookup for Ruby"
+HOMEPAGE="https://github.com/mime-types/ruby-mime-types"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 dev-ruby/minitest-bonus-assertions:2 )"
+
+ruby_add_rdepend ">=dev-ruby/mime-types-data-3.2015:3"
+
+all_ruby_prepare() {
+ # Avoid unneeded developer-only dependencies.
+ sed -i -e '/\(focus\|rg\)/ s:^:#:' \
+ -e 's:fivemat/::' test/minitest_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}