summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-03 07:23:30 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-04 07:01:58 +0200
commit43abb83d67316f4c007cb51fff6be63df850c7d6 (patch)
tree8893cadaa4e1bbca74b6144561212c4c31a5a121 /dev-ruby/mixlib-shellout
parentdev-ruby/mixlib-shellout: cleanup (diff)
downloadgentoo-43abb83d67316f4c007cb51fff6be63df850c7d6.tar.gz
gentoo-43abb83d67316f4c007cb51fff6be63df850c7d6.tar.bz2
gentoo-43abb83d67316f4c007cb51fff6be63df850c7d6.zip
dev-ruby/mixlib-shellout: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest1
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index 481394520e00..421ac9f2007f 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1 +1,2 @@
DIST mixlib-shellout-2.1.0.tar.gz 32800 SHA256 8dcc6ae1be5dc3055808b3d40a9155520e6188f1772f6f5e4ecf037ab7a5283d SHA512 15fef2f9b661ac02edecfd4c48b00866e34bc361f2070da4382991e0455ab15650327209cbcae153fcface727c47efc75d7f9dac2a92867fd148941942f117d8 WHIRLPOOL 7e039b721d73d2b4531a3d69224358c67e2afb3d051cd1cf21380a1c47b23523c2e1115184542999fee4f63f9bdafd64e4d67d3133d269043f2828449d374e02
+DIST mixlib-shellout-2.2.0.tar.gz 33057 SHA256 ee7165b51dce388d189eae1eddcffcde602c7819e8ec14c3fa97025077cbbb23 SHA512 3b6383d4b4c5b891a688c7aceb615ad08682030ecc840a95a8eb5d55978fafeb07e1bd62a53eb1f39aaca0b94d93260ec8e0824c43c1adf51cabccc66f869c22 WHIRLPOOL 5651933bc78179730f76814312591a4b7b2f48fbbd75644529bd43176ccfac23aa1960e04f85e1dcbbb16c655e9d326ef52cce75ed3561109776198325a6f70d
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.0.ebuild
new file mode 100644
index 000000000000..6d1fc6f7db65
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}