summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-05 07:50:41 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-05 08:00:27 +0100
commit9b35203edc17b1e197e20567710d542eff295670 (patch)
treea3f3fbbcb16f31867bb94692a9d9103337f58b1c /dev-ruby/mocha
parentx11-wm/amiwm: Bumped to EAPI-6 (diff)
downloadgentoo-9b35203edc17b1e197e20567710d542eff295670.tar.gz
gentoo-9b35203edc17b1e197e20567710d542eff295670.tar.bz2
gentoo-9b35203edc17b1e197e20567710d542eff295670.zip
dev-ruby/mocha: cleanup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/mocha')
-rw-r--r--dev-ruby/mocha/mocha-0.10.5-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-ruby/mocha/mocha-0.10.5-r1.ebuild b/dev-ruby/mocha/mocha-0.10.5-r1.ebuild
deleted file mode 100644
index c7f2c920e224..000000000000
--- a/dev-ruby/mocha/mocha-0.10.5-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 "
-
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
-HOMEPAGE="http://mocha.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0.10"
-KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- doc? ( dev-ruby/coderay )"
-
-ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
-
- # Use syntax that works with all versions of coderay
- sed -i -e 's/html.div/html(:wrap => :div)/' Rakefile || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- rake examples || die
- fi
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*.rb || die
-}