summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-07-11 05:20:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-07-11 05:21:46 -0500
commit4314fec93589364f07c37eeb7578a093ce8ef51c (patch)
tree102e846348e2cb4f00aed8321e347c0a39525a93 /dev-ruby/puppetdb-termini
parentapp-admin/puppetserver: fix init (diff)
downloadgentoo-4314fec93589364f07c37eeb7578a093ce8ef51c.tar.gz
gentoo-4314fec93589364f07c37eeb7578a093ce8ef51c.tar.bz2
gentoo-4314fec93589364f07c37eeb7578a093ce8ef51c.zip
dev-ruby/puppetdb-termini: needed for puppetserver
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-5.0.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 617e7f83e304..39739c6a985d 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1 +1,2 @@
DIST puppetdb-termini_4.3.0-1puppetlabs1_all.deb 18522 SHA256 02f7a02f42364ad7bd7455c3c0668561b51f9bf1efca38f06a751128f594d789 SHA512 088ed402df9d8fed0827cdca47c782690a7ab767e2fc786dd94a1019cd84c5dd70168bddac43963031c89bc3a1a545d81554952c9fdc999f52d49e2b6212f9ef WHIRLPOOL 63303fe0cfdb45ad9919e5af2ceef31237dcb50c11ed5109d2e113c2f657d8a141c06ad6a1b2e83d9fea0177f3c6772b42637f47e29531bd9834a1d306b2c81c
+DIST puppetdb-termini_5.0.1-1puppetlabs1_all.deb 18888 SHA256 c293884b47105001b50d1961029634b5ac6d17ba49fce5d9e32c39ca75585c2c SHA512 513155a86b23b52b30eea49da49562bf1fce513f1fc58d4c026a61542e4c197d4806cc51548ceaf98bb5a9b88a6b0166575852858f0c7144437372644d32f962 WHIRLPOOL 8aeecd2e09d5368c4adda8044f36f7fa89bee3eb6c0c556ffd11b6d77a5d2d6f1b87c8735f133c940b1c5fe69df2a64e34ba72d809a3182cd8967388e9b053ab
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-5.0.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-5.0.1.ebuild
new file mode 100644
index 000000000000..52fb80cef4d0
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-5.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/xenial/puppet5/${PN:0:1}/puppetdb/${PN}_${PV}-1puppetlabs1_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}