summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-30 08:39:29 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-30 08:56:07 +0200
commitd9b5b9023a3059b1132df5eac070021d6a459bb8 (patch)
treeb3be8969163371600f773ac34c98807c5eac5bae /dev-ruby/rcairo
parentdev-ruby/rcairo: avoid dependency on unpackaged gem, bug 626518 (diff)
downloadgentoo-d9b5b9023a3059b1132df5eac070021d6a459bb8.tar.gz
gentoo-d9b5b9023a3059b1132df5eac070021d6a459bb8.tar.bz2
gentoo-d9b5b9023a3059b1132df5eac070021d6a459bb8.zip
dev-ruby/rcairo: cleanup broken version
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/rcairo')
-rw-r--r--dev-ruby/rcairo/rcairo-1.15.9.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/dev-ruby/rcairo/rcairo-1.15.9.ebuild b/dev-ruby/rcairo/rcairo-1.15.9.ebuild
deleted file mode 100644
index ccd34ab91de6..000000000000
--- a/dev-ruby/rcairo/rcairo-1.15.9.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_NAME="cairo"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby bindings for cairo"
-HOMEPAGE="https://cairographics.org/rcairo/"
-
-IUSE=""
-
-SLOT="0"
-LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="${RDEPEND}
- >=x11-libs/cairo-1.2.0[svg]"
-DEPEND="${DEPEND}
- >=x11-libs/cairo-1.2.0[svg]"
-
-ruby_add_bdepend "
- >=dev-ruby/pkg-config-1.1.5
- dev-ruby/ruby-glib2
- test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
-
-all_ruby_prepare() {
- # Avoid development dependency.
- sed -i -e '/notify/ s:^:#:' test/cairo-test-utils.rb || die
-
- # Avoid unneeded dependency
- sed -i -e '/native-package-installer/ s:^:#:' ext/cairo/extconf.rb || die
-
- # Avoid test that requires unpackaged fixture
- sed -i -e '/sub_test_case..FreeTypeFontFace/,/^ end/ s:^:#:' test/test_font_face.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/cairo
-
- # again, try to make it more standard, to install it more easily.
- cp ext/cairo/cairo$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- # don't rely on the Rakefile because it's a mess to load with
- # their hierarchy, do it manually.
- ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
- -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- insinto $(ruby_get_hdrdir)
- doins ext/cairo/rb_cairo.h
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/samples
- doins -r samples/*
-}