summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-05-10 10:47:35 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-05-10 10:59:18 -0400
commit731be0be13e0690b5e71e70a764d9a0824139c39 (patch)
tree37a6698a65519410ca6cbba44c4a049ba935036f /dev-ruby/rex-exploitation
parentdev-ruby/rex-encoder: metasploit dep (diff)
downloadgentoo-731be0be13e0690b5e71e70a764d9a0824139c39.tar.gz
gentoo-731be0be13e0690b5e71e70a764d9a0824139c39.tar.bz2
gentoo-731be0be13e0690b5e71e70a764d9a0824139c39.zip
dev-ruby/rex-exploitation: metasploit dep
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest1
-rw-r--r--dev-ruby/rex-exploitation/metadata.xml14
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
new file mode 100644
index 000000000000..37dddf12ae79
--- /dev/null
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -0,0 +1 @@
+DIST rex-exploitation-0.1.12.gem 78848 SHA256 087fa124f9c383db8b8cda78e934393800174c06e9b7739dfc4be2b778c29eb8 SHA512 74716b4f23cb490fbc84e37269b12c58ce83ff903cf37b84685bc59838fe6c45f91082db063f9ced5e8270af6b27dad1cc6b836fb470a9a59be7c039f9ed7b2c WHIRLPOOL f3473c07a48d4ab4ea20686602fe4a3ed12e1a98c8170fdb81e95c45889ac27b6fd9214d2a00ad14aafba24d82d8d6e2d8d4e7161403ccf68b126bfebdbd476b
diff --git a/dev-ruby/rex-exploitation/metadata.xml b/dev-ruby/rex-exploitation/metadata.xml
new file mode 100644
index 000000000000..d75035c6a536
--- /dev/null
+++ b/dev-ruby/rex-exploitation/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/rex-exploitation</remote-id>
+ <remote-id type="rubygems">rex-exploitation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild
new file mode 100644
index 000000000000..111719427438
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/jsobfu
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}