summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-20 07:38:49 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-20 07:38:49 +0100
commit0b47ea7b504da998e7d9f48f5a235144d4e10e3c (patch)
treef74c267452b69d74c4e24f60b4de622286ab3b20 /dev-ruby/ruby-prof
parentdev-ruby/hashie: add 3.5.7 (diff)
downloadgentoo-0b47ea7b504da998e7d9f48f5a235144d4e10e3c.tar.gz
gentoo-0b47ea7b504da998e7d9f48f5a235144d4e10e3c.tar.bz2
gentoo-0b47ea7b504da998e7d9f48f5a235144d4e10e3c.zip
dev-ruby/ruby-prof: add 0.17.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.17.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index 2f1905d8baaa..3529e0521774 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1 +1,2 @@
DIST ruby-prof-0.16.2.tgz 87039 BLAKE2B 89a06edd36e7e70b978ce56b4cfea04f871538d2c35f25be3e46049d7fea863ad91006f87aa7ffb9afa4416c3e2aaafb7774c93804476dbc746b764c86d01c0e SHA512 4a070486375a40afd03c006385a14f5d2ae3670a658e1153b086d0e63eb7a87af38ae060c9d457cd67a5e084f75dd997cd39b890ef4a510bbae801838f74f7f8
+DIST ruby-prof-0.17.0.tgz 93492 BLAKE2B e573b77fb5f1134af99480efe3af706cade122c51bbef883cf0f915e359c695fe70485239fee7415288e99115146230bc803ec1976a39c6f5d743c10f0158744 SHA512 4e2a542420eced379a0326c0f48a041379a7a2aa06247e5cd9659f92b44ebcfca21d12a7bdf50f23ef0bdd6b37895b963a489a975ca84d487920c8fe52446d53
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.17.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.17.0.ebuild
new file mode 100644
index 000000000000..2a48a14c7e1e
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.17.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # Fix a timing-dependant spec since its thresholds for success are
+ # too tight.
+ sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}