summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/semantic_puppet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/semantic_puppet')
-rw-r--r--dev-ruby/semantic_puppet/Manifest1
-rw-r--r--dev-ruby/semantic_puppet/metadata.xml15
-rw-r--r--dev-ruby/semantic_puppet/semantic_puppet-0.1.1.ebuild21
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/semantic_puppet/Manifest b/dev-ruby/semantic_puppet/Manifest
new file mode 100644
index 000000000000..e00129da33b5
--- /dev/null
+++ b/dev-ruby/semantic_puppet/Manifest
@@ -0,0 +1 @@
+DIST semantic_puppet-0.1.1.gem 25088 SHA256 803dc62c61bbd7318197821590d8fe45f306ce8be4d1e54944ac7bfa1af2eff1 SHA512 9aa2ed9ae4194d85dd2c69b09ff128aef77f0fcb0ac2a3acd9dfbae970251d6ea9bf8cd7cab66f41553bc2693fb401d154e3ec4f0866d87106d39d1f347808fa WHIRLPOOL 774cb803c7e30aa341464b431d0678b7fbbff100ad4ac8b48285266dc70b5bf3f6d449db3670bcf0fdb2990635f758330b967abf47c264e59e0b468f6f1377b4
diff --git a/dev-ruby/semantic_puppet/metadata.xml b/dev-ruby/semantic_puppet/metadata.xml
new file mode 100644
index 000000000000..f013ed1dd53e
--- /dev/null
+++ b/dev-ruby/semantic_puppet/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <longdescription lang="en">
+ Library of useful tools for working with Semantic Versions and module dependencies.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">puppetlabs/semantic_puppet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/semantic_puppet/semantic_puppet-0.1.1.ebuild b/dev-ruby/semantic_puppet/semantic_puppet-0.1.1.ebuild
new file mode 100644
index 000000000000..a2468e811285
--- /dev/null
+++ b/dev-ruby/semantic_puppet/semantic_puppet-0.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library of useful tools for working with Semantic Versions and module dependencies."
+HOMEPAGE="https://github.com/puppetlabs/semantic_puppet"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""