summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/syntax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/syntax')
-rw-r--r--dev-ruby/syntax/Manifest2
-rw-r--r--dev-ruby/syntax/files/syntax-1.2.0-require-set.patch16
-rw-r--r--dev-ruby/syntax/metadata.xml8
-rw-r--r--dev-ruby/syntax/syntax-1.0.0-r4.ebuild30
-rw-r--r--dev-ruby/syntax/syntax-1.2.0-r1.ebuild24
5 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/syntax/Manifest b/dev-ruby/syntax/Manifest
new file mode 100644
index 000000000000..6c2efabc5ce2
--- /dev/null
+++ b/dev-ruby/syntax/Manifest
@@ -0,0 +1,2 @@
+DIST syntax-1.0.0.gem 15360 SHA256 605e2f62770bad04e849b3a1a2234e45b2904a8592f2f4dcc0bb14dce09c23fd SHA512 196c0bd125903f3579d7a02528be16b09db75dbf91f6f8efbaa4cd69229a52a2ae00841343c3b17bada86e6bda51d6cc7c0c119615a5d779332f61976af96c04 WHIRLPOOL f41df19ef0adddf0ef0424bf9e1070c2b2417bacba5f4a1d37051a5a19f82a75ada729f2ebd41f70dac7b455722b5c4d5e94dde1f7ec8235ea15116a968a4b86
+DIST syntax-1.2.0.tar.gz 40797 SHA256 9cec12fac6b6dc4f3fee263f5765333880ae26d4194b9670f3de26d4674dde9b SHA512 69804ab94203e2260b4c585aacf68db6ad8e47cf2339ffeb1105ae39da5f1d456b1413eeeef29f1c450bff19780e815b9b1b966b171de3b24595f759b36e6548 WHIRLPOOL 4eb23d481dbd56878ac024643d10069f644ac182813dc744fa61ea44a418d04caa738915a7a60ca85aff5bf90c35e92187e18a1adf168cd17265c06f2b3a4e66
diff --git a/dev-ruby/syntax/files/syntax-1.2.0-require-set.patch b/dev-ruby/syntax/files/syntax-1.2.0-require-set.patch
new file mode 100644
index 000000000000..34dec6c66506
--- /dev/null
+++ b/dev-ruby/syntax/files/syntax-1.2.0-require-set.patch
@@ -0,0 +1,16 @@
+commit 22430510b9662edd64e3792c560629daf8aebc82
+Author: Jan Berkel <jan@soundcloud.com>
+Date: Tue Apr 1 07:00:17 2014 -0400
+
+ Explicitly require 'set'.
+
+diff --git a/lib/syntax/lang/ruby.rb b/lib/syntax/lang/ruby.rb
+index edccda0..90eca56 100644
+--- a/lib/syntax/lang/ruby.rb
++++ b/lib/syntax/lang/ruby.rb
+@@ -1,4 +1,5 @@
+ require 'syntax'
++require 'set'
+
+ module Syntax
+
diff --git a/dev-ruby/syntax/metadata.xml b/dev-ruby/syntax/metadata.xml
new file mode 100644
index 000000000000..fc8cde902459
--- /dev/null
+++ b/dev-ruby/syntax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">dblock/syntax</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/syntax/syntax-1.0.0-r4.ebuild b/dev-ruby/syntax/syntax-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..8b2a006324a9
--- /dev/null
+++ b/dev-ruby/syntax/syntax-1.0.0-r4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Syntax highlighting for sourcecode and HTML"
+HOMEPAGE="http://syntax.rubyforge.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+all_ruby_prepare() {
+ # The yaml test case hangs. Remove it so we can at least run all
+ # other tests instead of skipping the whole test suite.
+ rm test/syntax/tc_yaml.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/ALL-TESTS.rb || die "tests failed"
+}
diff --git a/dev-ruby/syntax/syntax-1.2.0-r1.ebuild b/dev-ruby/syntax/syntax-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..db22069a41b7
--- /dev/null
+++ b/dev-ruby/syntax/syntax-1.2.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Syntax highlighting for sourcecode and HTML"
+HOMEPAGE="https://github.com/dblock/syntax"
+SRC_URI="https://github.com/dblock/syntax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test doc"
+
+RUBY_PATCHES=( "${P}-require-set.patch" )
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"