summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/test_construct
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/test_construct')
-rw-r--r--dev-ruby/test_construct/Manifest1
-rw-r--r--dev-ruby/test_construct/metadata.xml8
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.1.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/test_construct/Manifest b/dev-ruby/test_construct/Manifest
new file mode 100644
index 000000000000..11ec1d3bc18b
--- /dev/null
+++ b/dev-ruby/test_construct/Manifest
@@ -0,0 +1 @@
+DIST test_construct-2.0.1.gem 13312 SHA256 f24df07376a93a4cdaf3e953ddb3d2edfe833adeb3a4fc7fbfa02103e8a85ea8 SHA512 c9898beb04d23974dc5b66a9d7bb4a77cd040cc63b724108c4fc4b81f0680d23a9e09b96110c1b5458107d0c2c8714cbed8b2e81611eef8ca7fab92b31014e98 WHIRLPOOL 2a05a32a4dbe9fc6dfd11fa81ef1a58b0a759056311ab6d5074a1f79a0b0a27558d4c58952aabb07a3d1094a203771016b69e1288d1e767b95203e9322416328
diff --git a/dev-ruby/test_construct/metadata.xml b/dev-ruby/test_construct/metadata.xml
new file mode 100644
index 000000000000..280cf9b37e8c
--- /dev/null
+++ b/dev-ruby/test_construct/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">bhb/test_construct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/test_construct/test_construct-2.0.1.ebuild b/dev-ruby/test_construct/test_construct-2.0.1.ebuild
new file mode 100644
index 000000000000..e75210d29847
--- /dev/null
+++ b/dev-ruby/test_construct/test_construct-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.0.8
+ >=dev-ruby/mocha-0.14.0
+ dev-ruby/rspec:3
+)"
+
+all_ruby_prepare () {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}