summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/test_declarative
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/test_declarative')
-rw-r--r--dev-ruby/test_declarative/Manifest1
-rw-r--r--dev-ruby/test_declarative/metadata.xml8
-rw-r--r--dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/test_declarative/Manifest b/dev-ruby/test_declarative/Manifest
new file mode 100644
index 000000000000..936d4323d257
--- /dev/null
+++ b/dev-ruby/test_declarative/Manifest
@@ -0,0 +1 @@
+DIST test_declarative-0.0.5.tgz 2114 SHA256 b6c27a2c26f85ce5d8df20c66bad4ade67f2ef6b8fe2f7a8b7ae348b460ad83a SHA512 69641a56c38403a86a8562910aa5ab433476351cc0e5a1f2a640030bfb4f82b96bf724d911ce46ff75dfe934de50d6549304088ee85d5689990e0ce5d263c160 WHIRLPOOL 6aa10e278fc0c8c2524fbd749fd830905ea5a123980b876610ca3d00e04045de9d0697aae1b912487ae6d5f06e9b1166a39f85fcbfd63de0395cb81dd716ed83
diff --git a/dev-ruby/test_declarative/metadata.xml b/dev-ruby/test_declarative/metadata.xml
new file mode 100644
index 000000000000..67f8403c5af2
--- /dev/null
+++ b/dev-ruby/test_declarative/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">svenfuchs/test_declarative</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild b/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild
new file mode 100644
index 000000000000..6286a5efd6b8
--- /dev/null
+++ b/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22: fails due to minitest incompatabilities.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simply adds a declarative test method syntax to test/unit"
+HOMEPAGE="https://github.com/svenfuchs/test_declarative"
+SRC_URI="https://github.com/svenfuchs/test_declarative/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="svenfuchs-test_declarative-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test/test_declarative_test.rb || die "Tests failed."
+}