summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-10 08:15:41 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-10 08:15:41 +0100
commitc5d5e8dcb1f5ec231f1bbc4e47dcbe2dc8e50e1b (patch)
tree39b7a10f292ffbdb3eed0cf2f4e0f48971a7af43 /dev-ruby/thor
parentdev-ruby/webmock: add 1.22.6 (diff)
downloadgentoo-c5d5e8dcb1f5ec231f1bbc4e47dcbe2dc8e50e1b.tar.gz
gentoo-c5d5e8dcb1f5ec231f1bbc4e47dcbe2dc8e50e1b.tar.bz2
gentoo-c5d5e8dcb1f5ec231f1bbc4e47dcbe2dc8e50e1b.zip
dev-ruby/thor: add ruby22
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/thor-0.19.1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/dev-ruby/thor/thor-0.19.1.ebuild b/dev-ruby/thor/thor-0.19.1.ebuild
index 368089e51e8c..49bbfdedfb86 100644
--- a/dev-ruby/thor/thor-0.19.1.ebuild
+++ b/dev-ruby/thor/thor-0.19.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -23,7 +23,10 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="doc"
-ruby_add_bdepend "
+# fakeweb is not compatible with ruby22. Upstream has switched to
+# webmock but leads to circular dependencies via childlabor's
+# dependencies, so skip tests for ruby22 for now.
+USE_RUBY="ruby20 ruby21" ruby_add_bdepend "
test? (
>=dev-ruby/fakeweb-1.3
dev-ruby/childlabor
@@ -46,3 +49,14 @@ all_ruby_prepare() {
# bug 430402
sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby22)
+ einfo "Skipping tests due to circular dependencies"
+ ;;
+ *)
+ ruby-ng_rspec spec || die
+ ;;
+ esac
+}