summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-13 07:39:30 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-13 07:43:05 +0200
commit3b426b3fc7a83c0207c8e27df1cf431531fe15cc (patch)
treeda15e655ce7073273ad84532cb978d53334655a3 /dev-ruby
parentmedia-libs/libvpx: Stable for PPC64 (bug #585350). (diff)
downloadgentoo-3b426b3fc7a83c0207c8e27df1cf431531fe15cc.tar.gz
gentoo-3b426b3fc7a83c0207c8e27df1cf431531fe15cc.tar.bz2
gentoo-3b426b3fc7a83c0207c8e27df1cf431531fe15cc.zip
dev-ruby/activesupport: add rails 4.1.16
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-4.1.16.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index d2398e05a050..c1bf85fdc3ee 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,4 +1,5 @@
DIST rails-3.2.22.2.tgz 3571822 SHA256 6aaef5723f3a409d057ace5500f1743168bde8f45114d9b5d861bb6e05444356 SHA512 b0c1817164168e2b8ae5b748dd1dd88097c2047d2e2eb31e403a5b865a1e50c43f8841a0e60ccdda6d5a859bba9acdfb06462cb8ba93a3e9ecc57dc349f8be13 WHIRLPOOL 8f5e674020a4c00a9a5da6e2e25aceb408ccb01f8adce74128a99cbb602d08da31de44b496a42d86bbf3887830785bfb961c95231d98bb1ce5d17755741dd3e1
DIST rails-4.0.13.tgz 3761572 SHA256 a693a8c5f767d153e765634cecb6356855ca51b6554b3af1a38888023a204a51 SHA512 3f2cca90187f800d1ec57fc6cbc58c1f3213113a94d1dee7d9cfd3dc0264b7f3a9c6cfc6dd95ef2fb3aa7d8ca5d6da50cedecc288ff8ff7e5305dc0309b4365d WHIRLPOOL a5b3f7f828a88d04b5687b3217b40903192ccea5eca36ca58cbb2baeec7471241fe5529f13688bd1f6396a384cf282c94bfaf54ee1cfafdf5ef400707dee7d01
DIST rails-4.1.15.tgz 3729946 SHA256 df54609b05298f5c0c9eb4e00bb82c61133d955021fe58ffab2efacd76ac6ce5 SHA512 0a8c944fece6c060718f0c7769ae80baa161357ac8b49e69a11e9bbf43476c633cd3ed51b13e3c0f364e47b3167879de5f57146e76f01a59e026b97166aeba2c WHIRLPOOL 75fbd9a1e7b988c47c7a26bffb5e58cd2c33af9a5e83b03ecee09b35c7497d82aa580fd20dbdf34237b9d9594ed772a346e32d6430becc1fdf854581c8ebef8e
+DIST rails-4.1.16.tgz 3730763 SHA256 fd17ccacee3a61c17d2cfa36db36f583ed3d05eac504e4bb06ec65629965f499 SHA512 d342ab0ede9f4642d809114fb8518d09a63da8bda66f866f2f81646b247d7da2235e81f818793ae86c4c2365624d5b35898d4f1693093019d3639a1dcb872ac1 WHIRLPOOL fe1bc9866c5005f8232a3d339811afe183aef53c1f1d8a8a9250b447e941309cb415592309d8bb3367add028a98c5cdb4cc6180d0f49e1c76337668763460536
DIST rails-4.2.6.tgz 4179056 SHA256 68bf40c27e0ee75b26c7b48fbe357f024b8d6d322a4ecf5c3427b4d6ef959fef SHA512 040599aa1c6a09ca569f377b1f49a4404d9516599d16d6909f93ffd2e387dfb20835a2842980cc5c119aaef411985e47f55ec8907041ff633b8f98ea101a42d0 WHIRLPOOL 1aef2ff5790fa94f1003fa6acdcad26b7bcb6a6a02f075e41a6ba5a5b77790420afa57ea64d3192e92de595161ba3741e7e7f8be7dbac6871ba5137a53f81efe
diff --git a/dev-ruby/activesupport/activesupport-4.1.16.ebuild b/dev-ruby/activesupport/activesupport-4.1.16.ebuild
new file mode 100644
index 000000000000..b628f0e8e5f1
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.1.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.1:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
+
+ # Avoid test that fails with Minitest 5.4 since that already defines
+ # a string E in its TestCase.
+ rm test/core_ext/marshal_test.rb || die
+ sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
+}