summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-11-02 11:06:58 +0100
committerHans de Graaff <graaff@gentoo.org>2019-11-02 11:06:58 +0100
commita0d7a8e65572c556c779d30dcea7c2f78528ba42 (patch)
tree6b7e59eca72521102de472591bfcd1db94c2c1c2 /dev-ruby
parentdev-ruby/pkg-config: cleanup (diff)
downloadgentoo-a0d7a8e65572c556c779d30dcea7c2f78528ba42.tar.gz
gentoo-a0d7a8e65572c556c779d30dcea7c2f78528ba42.tar.bz2
gentoo-a0d7a8e65572c556c779d30dcea7c2f78528ba42.zip
dev-ruby/pg: cleanup
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.0.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 7e6f051fc1dc..52dd737506a2 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,3 +1,2 @@
DIST pg-0.21.0.gem 214016 BLAKE2B 9e27646cd85bc97dedfb980f4851b19a1ef2aad17f6a5c60726c1683642af5c4cf87d518b300fb4c894e1580f808f8af6158b57f1ac25971c1fc55818abee6f4 SHA512 590a8c34487d2cf030082cfff87b2cc83b636df06a931e394acfb098ecb5728e793d777f125b036ee9953bbd21ec5facf91c932930acccb507d3394f2fc4cc5b
-DIST pg-1.0.0.gem 213504 BLAKE2B eecaa632c7903f89c503ad92ccff058bbc6c2c80cbf83d656eeb9a5b919b84bb270671ad4e0fa08f55be1bcfc69eb8e13b815c37c601d300de503383f1ba5908 SHA512 1cac025ab8a95b4429534b98377eedeb1e3f8b2c4a859363c4174d477577caf39557b002cde4e745189fa9a29e9181ff9d564d822f15ff5c4f03f7389b0d0398
DIST pg-1.1.4.gem 233984 BLAKE2B 5a92ca49f8e471905286c07dc468f2932461f73fba13d2786c50883b271e2528b4476a81737023c252e75784c49113aacc50e1722fa100d5e97494fe60965a41 SHA512 442eadb4e9fe51aaef71cb5bbe8786c61dc4cfaa1241491270cb251f062abae88b6b2ef88dec7ab6ba2baa6390e954a2fcf4862cc95be4bc516e029c788fa1d9
diff --git a/dev-ruby/pg/pg-1.0.0.ebuild b/dev-ruby/pg/pg-1.0.0.ebuild
deleted file mode 100644
index 199ef0824212..000000000000
--- a/dev-ruby/pg/pg-1.0.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="1"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND+=" dev-db/postgresql:*"
-DEPEND+=" dev-db/postgresql
- test? ( >=dev-db/postgresql-9.4[server,threads] )"
-
-all_ruby_prepare() {
- # hack the Rakefile to make it sure that it doesn't load
- # rake-compiler (so that we don't have to depend on it and it
- # actually works when building with USE=doc).
- sed -i \
- -e '/Rakefile.cross/s:^:#:' \
- -e '/ExtensionTask/,/^end$/ s:^:#:' \
- Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/*$(get_libname) lib || die
-}
-
-each_ruby_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- RSPEC_VERSION=3 ruby-ng_rspec
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}